summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2023-01-14 09:34:44 +0300
committerYurii Kolesnykov2023-01-18 16:28:23 +0300
commitad6d8b7ee67e10fb8d73026adfbdbfb621c0b113 (patch)
tree106781a5651e1fdf6c6f6d81b188fc05f1eae1ed
parent50be13ebd2e1278b163ebf05fa4f4da26686ca69 (diff)
downloadaur-ad6d8b7ee67e10fb8d73026adfbdbfb621c0b113.tar.gz
sync with testing/linux
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--config3
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c918b13d928f..bdc0e4a5981c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-drm-next-git
pkgdesc = Linux kernel with bleeding-edge GPU drivers
- pkgver = 6.2.r1153517.f422fa7cd858
- pkgrel = 2
+ pkgver = 6.2.r1154080.0b45ac1170ea
+ pkgrel = 1
url = https://cgit.freedesktop.org/drm/drm
arch = x86_64
license = GPL2
@@ -12,8 +12,9 @@ pkgbase = linux-drm-next-git
makedepends = perl
makedepends = tar
makedepends = xz
+ makedepends = gettext
makedepends = xmlto
- makedepends = python-sphinx<6.0.0
+ makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
makedepends = graphviz
makedepends = imagemagick
@@ -23,7 +24,7 @@ pkgbase = linux-drm-next-git
source = linux-drm-next-git::git+https://anongit.freedesktop.org/git/drm/drm#branch=drm-next
source = config
sha256sums = SKIP
- sha256sums = 0571ea17a2e38458096b679418197bbea8c414388f628d122517f3a1f3a31b3a
+ sha256sums = 1efa33aea067fa920880ef7fef3ec82f8d4cde21213eda34ac6534ca6879fca0
pkgname = linux-drm-next-git
pkgdesc = The Linux kernel with bleeding-edge GPU drivers kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 6f6f8d3459cb..359e3459eae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Yurii Kolesykov <root@yurikoles.com>
-# based on testing/linux: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Based on testing/linux by Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-drm-next-git
-pkgver=6.2.r1153517.f422fa7cd858
-pkgrel=2
+pkgver=6.2.r1154080.0b45ac1170ea
+pkgrel=1
pkgdesc='Linux kernel with bleeding-edge GPU drivers'
_product="${pkgbase%-git}"
_branch="${_product#linux-}"
@@ -11,8 +11,8 @@ arch=(x86_64)
url='https://cgit.freedesktop.org/drm/drm'
license=(GPL2)
makedepends=(
- bc libelf pahole cpio perl tar xz
- xmlto 'python-sphinx<6.0.0' python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
+ bc libelf pahole cpio perl tar xz gettext
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
options=('!strip')
@@ -22,7 +22,7 @@ source=(
config # the main kernel config file
)
sha256sums=('SKIP'
- '0571ea17a2e38458096b679418197bbea8c414388f628d122517f3a1f3a31b3a')
+ '1efa33aea067fa920880ef7fef3ec82f8d4cde21213eda34ac6534ca6879fca0')
pkgver() {
cd $_srcname
diff --git a/config b/config
index ca0e505ed261..ceb2e1c494f6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.1.0-arch1 Kernel Configuration
+# Linux/x86 6.1.6-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -206,6 +206,7 @@ CONFIG_ARCH_SUPPORTS_NUMA_BALANCING=y
CONFIG_ARCH_WANT_BATCHED_UNMAP_TLB_FLUSH=y
CONFIG_CC_HAS_INT128=y
CONFIG_CC_IMPLICIT_FALLTHROUGH="-Wimplicit-fallthrough=5"
+CONFIG_GCC11_NO_ARRAY_BOUNDS=y
CONFIG_GCC12_NO_ARRAY_BOUNDS=y
CONFIG_CC_NO_ARRAY_BOUNDS=y
CONFIG_ARCH_SUPPORTS_INT128=y