summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Noonan2018-02-17 14:08:08 -0800
committerSteven Noonan2018-02-17 14:08:08 -0800
commit986753af28b357071ebef1cb25f7042ba4157706 (patch)
tree8c985628c2a3e8e4c2987f1aba5e380c07153c19
parentd18e3e508d921de4d4e951baa83c563e1ca09949 (diff)
downloadaur-986753af28b357071ebef1cb25f7042ba4157706.tar.gz
linux-ec2: upgrade to 4.15.4
Signed-off-by: Steven Noonan <steven@uplinklabs.net>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
2 files changed, 58 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 288d121710a5..c57d535d9516 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by makepkg 5.0.2
-# Thu Feb 15 14:36:07 UTC 2018
+# Sat Feb 17 22:07:44 UTC 2018
pkgbase = linux-ec2
- pkgver = 4.15.3
+ pkgver = 4.15.4
pkgrel = 1
url = https://git.uplinklabs.net/steven/projects/archlinux/ec2/ec2-packages.git/tree/linux-ec2
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = linux-ec2
options = !strip
source = http://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz
source = http://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.sign
- source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.3.xz
- source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.3.sign
+ source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.4.xz
+ source = http://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.4.sign
source = config.x86_64
source = 60-linux.hook
source = 90-linux.hook
@@ -26,7 +26,7 @@ pkgbase = linux-ec2
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769
sha256sums = SKIP
- sha256sums = 6dd42389603bc6c83d2e6db1d736303e41d26cef479cad926b87711f261c9c35
+ sha256sums = 5f8344fcc6b15be5f53001bb18df342bf5877563239f03271c236e3a40db89e8
sha256sums = SKIP
sha256sums = 24c4bddca64e232a9af6c0a6193cbd4e9a36e2c060f46ffa73bcbc45c41345cb
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
@@ -42,17 +42,17 @@ pkgname = linux-ec2
depends = kmod
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
- provides = linux=4.15.3
+ provides = linux=4.15.4
options = strip
options = debug
backup = etc/mkinitcpio.d/linux-ec2.preset
pkgname = linux-ec2-headers
pkgdesc = Header files and scripts for building modules for linux-ec2 kernel
- provides = linux-headers=4.15.3
+ provides = linux-headers=4.15.4
options = !strip
pkgname = linux-ec2-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the linux-ec2 kernel
- provides = linux-docs=4.15.3
+ provides = linux-docs=4.15.4
diff --git a/PKGBUILD b/PKGBUILD
index a1b041b8f17e..94a2c0df7adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,47 @@
# Maintainer: Steven Noonan <steven@uplinklabs.net>
pkgbase=linux-ec2
-_srcname=linux-4.15
-pkgver=4.15.3
+_branch=4.15
+_build_from=tarball
+#_build_from=git
+#_build_from=git-mirror
+pkgver=4.15.4
pkgrel=1
arch=('x86_64')
url="https://git.uplinklabs.net/steven/projects/archlinux/ec2/ec2-packages.git/tree/linux-ec2"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+case $_build_from in
+ tarball)
+ _srcname=linux-${_branch}
+ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
+ "http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
+ "http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign")
+ sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
+ 'SKIP'
+ '5f8344fcc6b15be5f53001bb18df342bf5877563239f03271c236e3a40db89e8'
+ 'SKIP')
+ ;;
+ git)
+ _srcname=linux
+ makedepends+=('git')
+ source=("${_srcname}::git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git#branch=linux-$_branch.y")
+ sha256sums=('SKIP')
+ ;;
+ git-mirror)
+ _srcname=linux
+ makedepends+=('git')
+ source=("${_srcname}::git+https://git.uplinklabs.net/steven/mirrors/linux/stable/linux-stable.git#branch=linux-$_branch.y")
+ sha256sums=('SKIP')
+ ;;
+ *)
+ error "Unknown _build_from setting '$_build_from'"
+ exit 1
+esac
+
+source+=(
# the main kernel config file
'config.x86_64'
# pacman hook for depmod
@@ -23,10 +52,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'0001-xhci-demote-annoying-warning.patch'
)
-sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
- 'SKIP'
- '6dd42389603bc6c83d2e6db1d736303e41d26cef479cad926b87711f261c9c35'
- 'SKIP'
+sha256sums+=(
'24c4bddca64e232a9af6c0a6193cbd4e9a36e2c060f46ffa73bcbc45c41345cb'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
@@ -39,15 +65,24 @@ validpgpkeys=(
_kernelname=${pkgbase#linux}
+if [[ $_build_from == git* ]]; then
+ pkgver() {
+ cd ${_srcname}
+ git describe --always | sed 's|^v||g;s|-|_|g'
+ }
+fi
+
prepare() {
cd ${_srcname}
- dots="${pkgver//[^.]}"
- dotcount="${#dots}"
+ if [[ $_build_from == tarball ]]; then
+ dots="${pkgver//[^.]}"
+ dotcount="${#dots}"
- # add upstream patch
- if [ "$dotcount" -gt 1 ]; then
- patch -Np1 -i "${srcdir}/patch-${pkgver}"
+ # add upstream patch
+ if [ "$dotcount" -gt 1 ]; then
+ patch -Np1 -i "${srcdir}/patch-${pkgver}"
+ fi
fi
# add latest fixes from stable queue, if needed