summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyano Hao2021-05-21 08:01:02 +0800
committerCyano Hao2021-05-21 08:01:02 +0800
commit23eef6b655444101d67dfd6b84e0a201018c33b8 (patch)
tree3cc70052d9066efc0e97f45e398af385388ca6ae
downloadaur-23eef6b655444101d67dfd6b84e0a201018c33b8.tar.gz
el8 240.22.1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD55
-rw-r--r--linux-el.install11
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95cc6443d9e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = linux-el-bin
+ pkgdesc = The Enterprise Linux kernel, modules and headers (Rocky Linux binary)
+ pkgver = 240.22.1
+ pkgrel = 1
+ epoch = 8
+ url = https://www.kernel.org/
+ install = linux-el.install
+ arch = x86_64
+ license = GPL2
+ depends = coreutils
+ depends = kmod
+ depends = initramfs
+ options = !strip
+ source = https://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/Packages/kernel-core-4.18.0-240.22.1.el8.x86_64.rpm
+ source = https://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/Packages/kernel-modules-4.18.0-240.22.1.el8.x86_64.rpm
+ source = https://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/Packages/kernel-devel-4.18.0-240.22.1.el8.x86_64.rpm
+ sha256sums = bba3049faaee909ba055f495012a49cb885db357048e967a41d79aa1d5822465
+ sha256sums = 6360d8c98d127b00b2b7b6bc28b14f5b738642f699909a5e660161066a437f23
+ sha256sums = 8791ee1dc248f4ec347f2b254bf1c39e7e8a71c4a61b3996dd0c989c3acbe098
+
+pkgname = linux-el-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ae9b7a070a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+kernel-core-*.rpm
+kernel-modules-*.rpm
+kernel-devel-*.rpm
+kernel-doc-*.rpm
+
+linux-el-*.pkg.tar*
+
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8909b0f521c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Cyano Hao <c@cyano.cn>
+
+_pkgbase=linux-elbin # for mkinitcpio hook
+pkgname=linux-el-bin
+_basever=4.18.0
+pkgver=240.22.1
+epoch=8 # indicates RHEL major version
+pkgrel=1
+# pkgdesc="The Enterprise Linux kernel, modules, headers and documentation (pre-built binary)"
+pkgdesc="The Enterprise Linux kernel, modules and headers (Rocky Linux binary)"
+url="https://www.kernel.org/"
+arch=(x86_64)
+license=(GPL2)
+depends=(coreutils kmod initramfs)
+options=('!strip')
+install=linux-el.install
+
+# corresponding packages (rhel -> archlinux)
+# kernel -> N/A (meta package)
+# ✓ kernel-core -> linux
+# ✓ kernel-modules -> linux
+# kernel-modules-extra -> N/A (obsolete)
+# ✓ kernel-devel -> linux-headers
+# ○ kernel-doc -> linux-docs (currently bsdtar cannot extract it)
+# kernel-headers -> linux-api-headers
+# kernel-tools -> N/A (misc userland utils)
+
+_rocky_mirror="https://download.rockylinux.org/pub/rocky"
+_rpmver=$_basever-$pkgver.el$epoch
+source=(
+ "$_rocky_mirror/$epoch/BaseOS/x86_64/os/Packages/kernel-core-$_rpmver.x86_64.rpm"
+ "$_rocky_mirror/$epoch/BaseOS/x86_64/os/Packages/kernel-modules-$_rpmver.x86_64.rpm"
+ "$_rocky_mirror/$epoch/BaseOS/x86_64/os/Packages/kernel-devel-$_rpmver.x86_64.rpm"
+ # "$_rocky_mirror/$epoch/BaseOS/x86_64/os/Packages/kernel-doc-$_rpmver.noarch.rpm"
+)
+sha256sums=('bba3049faaee909ba055f495012a49cb885db357048e967a41d79aa1d5822465'
+ '6360d8c98d127b00b2b7b6bc28b14f5b738642f699909a5e660161066a437f23'
+ '8791ee1dc248f4ec347f2b254bf1c39e7e8a71c4a61b3996dd0c989c3acbe098')
+
+package() {
+ cd "$srcdir"
+
+ # kernel image and modules
+ install -m755 -d "$pkgdir"/usr/lib/modules/
+ cp -r lib/modules/$_rpmver.x86_64/ "$pkgdir"/usr/lib/modules/$_rpmver.x86_64
+ echo $_pkgbase >"$pkgdir"/usr/lib/modules/$_rpmver.x86_64/pkgbase # mkinitcpio hook
+
+ # headers
+ # dkms hook requires headers in module directory
+ rm "$pkgdir"/usr/lib/modules/$_rpmver.x86_64/build
+ cp -r usr/src/kernels/$_rpmver.x86_64/ "$pkgdir"/usr/lib/modules/$_rpmver.x86_64/build
+ # symlink
+ install -m755 -d "$pkgdir"/usr/src/
+ ln -s ../lib/modules/$_rpmver.x86_64/build "$pkgdir"/usr/src/$_pkgbase
+}
diff --git a/linux-el.install b/linux-el.install
new file mode 100644
index 000000000000..73629f2d03f2
--- /dev/null
+++ b/linux-el.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo 'WARNING!'
+ echo
+ echo ' Enterprise Linux 8 has very limited support for file systems.'
+ echo ' Check Red Hat’s documentation for details.'
+ echo ' https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/managing_file_systems/overview-of-available-file-systems_managing-file-systems'
+ echo
+ echo ' Zstandard-compressed initramfs is not supported. Use GZip or XZ instead.'
+ echo
+}