summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemesys2022-02-20 22:32:53 -0500
committernemesys2022-02-20 22:32:53 -0500
commit4baf7e4b1e7a76eb29b59a6c06dfaeccc66df50e (patch)
tree74f772c976d6c361ddcb0197cc115ea0ef1a65bb
parent1fb50af52ac8adacea4f74bbbf63a821d0b08ecf (diff)
downloadaur-4baf7e4b1e7a76eb29b59a6c06dfaeccc66df50e.tar.gz
updated PKGBUILD to add correct change directory structure
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b9f349b9fcd..8fe07e9a1072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -107,7 +107,7 @@ export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
- cd $_srcname
+ cd linux-${pkgver}
echo "Setting version..."
scripts/setlocalversion --save-scmversion
@@ -192,7 +192,7 @@ prepare() {
}
build() {
- cd $_srcname
+ cd linux-${pkgver}
make all
make htmldocs
}
@@ -205,7 +205,7 @@ _package() {
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
- cd $_srcname
+ cd linux-${pkgver}
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
@@ -232,7 +232,7 @@ _package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
- cd $_srcname
+ cd linux-${pkgver}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing build files..."
@@ -302,8 +302,8 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- echo "Stripping vmlinux..."
- strip -v $STRIP_STATIC "$builddir/vmlinux"
+ #echo "Stripping vmlinux..."
+ #strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
@@ -313,7 +313,7 @@ _package-headers() {
_package-docs() {
pkgdesc="Documentation for the $pkgdesc kernel"
- cd $_srcname
+ cd linux-${pkgver}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
echo "Installing documentation..."