summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-16 00:54:17 -0400
committerChris Severance2015-09-16 00:54:17 -0400
commitcc7713212319e20623a5592dd0deea3354a9c3e5 (patch)
treef86b483fc5de92331eef3dcfd3aacf78d0a5b704
downloadaur-cc7713212319e20623a5592dd0deea3354a9c3e5.tar.gz
Initial Import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7bfe0d1f4a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = linux-firewire-utils
+ pkgdesc = list and change the configuration of connected FireWire devices. Formerly jujuutils
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/cladisch/linux-firewire-utils
+ arch = i686
+ arch = x86_64
+ license = GPL
+ replaces = jujuutils
+ source = linux-firewire-utils-0.4.tar.gz::https://github.com/cladisch/linux-firewire-utils/archive/v0.4.tar.gz
+ sha256sums = 5e80636dbbb90569700fc2fa6740f08e82c48237d340ea8cec4fda1e46997ef7
+
+pkgname = linux-firewire-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c63d71d51c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+_gitauth='cladisch'
+_pkgname='linux-firewire-utils'
+pkgname="${_pkgname}"
+pkgver='0.4'
+pkgrel='1'
+pkgdesc='list and change the configuration of connected FireWire devices. Formerly jujuutils'
+arch=('i686' 'x86_64')
+#url="http://code.google.com/p/jujuutils/"
+url="https://github.com/${_gitauth}/${_pkgname}"
+license=('GPL')
+replaces=('jujuutils')
+_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
+#source=("http://jujuutils.googlecode.com/files/jujuutils-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('5e80636dbbb90569700fc2fa6740f08e82c48237d340ea8cec4fda1e46997ef7')
+
+prepare() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ if [ ! -s 'configure' ]; then
+ aclocal
+ autoconf
+ automake --add-missing
+ fi
+ ./configure --prefix='/usr'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make -s # -j "$(nproc)" # Too small for parallel make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ set +u
+}
+set +u