summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author7Ji2022-11-07 08:11:09 +0800
committer7Ji2022-11-07 08:11:09 +0800
commita8db3576a7782f14d9c0e552fea54f23bb485576 (patch)
tree75f22e78662d33685ac6af6d1ba1d619fa6b81f0
parentbb849d5121cda079f0c5862302077eea634b320b (diff)
downloadaur-a8db3576a7782f14d9c0e552fea54f23bb485576.tar.gz
correct URL and source according to FabioLolix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e70b3a91e182..4ac111b8042a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = linux-firmware-amlogic-ophub
pkgdesc = Firmware files for Linux - mainly for Aarch64 Amlogic platform, collected by ophub
pkgver = 20220916
pkgrel = 1
- url = https://github.com/ophub/amlogic-s9xxx-armbian/raw/main/build-armbian/amlogic-armbian/firmware.tar.xz
+ url = https://github.com/ophub/amlogic-s9xxx-armbian
arch = aarch64
license = GPL2
license = GPL3
@@ -10,7 +10,7 @@ pkgbase = linux-firmware-amlogic-ophub
provides = linux-firmware=20220916
conflicts = linux-firmware
options = !strip
- source = https://github.com/ophub/amlogic-s9xxx-armbian/raw/main/build-armbian/amlogic-armbian/firmware.tar.xz
- sha256sums = 0fe946da8ef60465b21356493c80481ec36f31e8e492ee816f2eeff999757e36
+ source = https://github.com/ophub/amlogic-s9xxx-armbian/archive/099c353680b9f4584a7f71152b0a15d70d8fe114.tar.gz
+ sha256sums = 7b0306993117d95a7ed33f138457fa90b7d231c1aa6833bbe7e2c55c8aae1543
pkgname = linux-firmware-amlogic-ophub
diff --git a/PKGBUILD b/PKGBUILD
index f86fb40c1efb..11a60d6580e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: 7Ji <pugokughin@gmail.com>
+_repo='amlogic-s9xxx-armbian'
+_commit='099c353680b9f4584a7f71152b0a15d70d8fe114' # The current newest commit, although the firmware in it is not affected for a few commits after 20220916
+
pkgname=linux-firmware-amlogic-ophub
pkgver=20220916
pkgrel=1
pkgdesc="Firmware files for Linux - mainly for Aarch64 Amlogic platform, collected by ophub"
arch=('aarch64')
-url="https://github.com/ophub/amlogic-s9xxx-armbian/raw/main/build-armbian/amlogic-armbian/firmware.tar.xz"
+url="https://github.com/ophub/${_repo}"
license=('GPL2' 'GPL3' 'custom')
provides=("linux-firmware=${pkgver}")
conflicts=('linux-firmware')
options=(!strip)
source=(
- "${url}"
+ "${url}/archive/${_commit}.tar.gz"
)
sha256sums=(
- '0fe946da8ef60465b21356493c80481ec36f31e8e492ee816f2eeff999757e36'
+ '7b0306993117d95a7ed33f138457fa90b7d231c1aa6833bbe7e2c55c8aae1543'
)
package() {
install -d -m 755 "${pkgdir}"/usr
- mv -v "${srcdir}/lib" "${pkgdir}/usr/"
+ tar -C "${pkgdir}"/usr -xvJf "${srcdir}/${_repo}-${_commit}/build-armbian/amlogic-armbian/firmware.tar.xz"
} \ No newline at end of file