summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalazs Vinarz2019-10-03 11:25:56 +0200
committerBalazs Vinarz2019-10-03 11:35:34 +0200
commitb5a39413f38290197e0759e43f1816a56e81eab9 (patch)
tree107eb9a9b363381e42623aa2455235e700653748
downloadaur-b5a39413f38290197e0759e43f1816a56e81eab9.tar.gz
first upload, based on the Arch linux-firmware pkg
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff759b48df15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = linux-firmware-minimal
+ pkgdesc = Minimal amount of firmware files for Linux, mostly recommended for virtual systems.
+ pkgver = 20100519
+ pkgrel = 1
+ url = https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/
+ arch = any
+ license = GPL2
+ license = GPL3
+ license = MIT
+ license = custom
+ conflicts = linux-firmware-git
+ conflicts = linux-firmware
+ options = !strip
+ source = http://th.archive.ubuntu.com/archlinux/other/linux-firmware/linux-firmware-minimal-20100519.tar.xz
+ sha256sums = 2c0d22e9ce469d8095c1c4921350ea6021088ce21b5a46139f4ed8c6003dad01
+
+pkgname = linux-firmware-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b3ea2d6e3a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Balazs Vinarz <vinibali1 at gmail dot com>
+
+pkgname=linux-firmware-minimal
+pkgver=20100519
+pkgrel=1
+pkgdesc="Minimal amount of firmware files for Linux, mostly recommended for virtual systems."
+arch=('any')
+url="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/"
+license=('GPL2' 'GPL3' 'MIT' 'custom')
+conflicts=('linux-firmware-git'
+ 'linux-firmware')
+options=(!strip)
+source=(http://th.archive.ubuntu.com/archlinux/other/linux-firmware/$pkgname-$pkgver.tar.xz)
+sha256sums=('2c0d22e9ce469d8095c1c4921350ea6021088ce21b5a46139f4ed8c6003dad01')
+
+build() {
+ :
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -d -m755 "${pkgdir}/lib/firmware"
+ cp -a * "${pkgdir}/lib/firmware/"
+ install -d -m755 "${pkgdir}/usr/share/licenses/linux-firmware/"
+ mv "${pkgdir}/lib/firmware"/LICEN* "${pkgdir}/usr/share/licenses/linux-firmware/"
+}
+# vim:set ts=2 sw=2 et: