summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Schoenick2019-10-16 13:15:57 -0700
committerJohn Schoenick2019-10-16 13:15:57 -0700
commit24adfe1c0b409a921db27bfe4fc02c23848bc731 (patch)
tree00cd58867b1f917762ee7527d1dd16259e7debc6
parented02638ae8ca5e752022c9e5c32e6a99f43c7196 (diff)
parent3f25259f67eaee0dd61c0ef8127330492266cbf9 (diff)
downloadaur-24adfe1c0b409a921db27bfe4fc02c23848bc731.tar.gz
Merge branch 'upstream' for 5.3.6
-rw-r--r--.SRCINFO10
-rw-r--r--60-linux.hook1
-rw-r--r--PKGBUILD30
3 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eb89e383ae7..96b6dac8fb22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Oct 7 21:32:03 UTC 2019
+# Wed Oct 16 20:15:44 UTC 2019
pkgbase = linux-fsync
- pkgver = 5.3.5.arch1
+ pkgver = 5.3.6.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.3.5-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.3.6-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -17,7 +17,7 @@ pkgbase = linux-fsync
makedepends = graphviz
makedepends = imagemagick
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.3.5-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.3.6-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -25,7 +25,7 @@ pkgbase = linux-fsync
source = futex-wait-multiple-5.2.1.patch
sha256sums = SKIP
sha256sums = 7d09d1d79a4ecb82502b4483cf989ede3f643e05613de45e12563dfe85d80423
- sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
+ sha256sums = 452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c
sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
sha256sums = b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942
diff --git a/60-linux.hook b/60-linux.hook
index b33873c854fb..584ce35372b0 100644
--- a/60-linux.hook
+++ b/60-linux.hook
@@ -4,7 +4,6 @@ Operation = Install
Operation = Upgrade
Operation = Remove
Target = usr/lib/modules/%KERNVER%/*
-Target = usr/lib/modules/%EXTRAMODULES%/*
[Action]
Description = Updating %PKGBASE% module dependencies...
diff --git a/PKGBUILD b/PKGBUILD
index 39c1f6008a20..8184f8f91dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-fsync # Build kernel with a different name
-_srcver=5.3.5-arch1
+_srcver=5.3.6-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -31,7 +31,7 @@ validpgpkeys=(
)
sha256sums=('SKIP'
'7d09d1d79a4ecb82502b4483cf989ede3f643e05613de45e12563dfe85d80423'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
+ '452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942')
@@ -60,8 +60,8 @@ prepare() {
cp ../config .config
make olddefconfig
- make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ make -s kernelrelease > version
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
}
build() {
@@ -77,11 +77,10 @@ _package() {
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
+ cd $_srcname
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- cd $_srcname
-
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
@@ -94,13 +93,6 @@ _package() {
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # a place for external modules,
- # with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
-
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -109,7 +101,6 @@ _package() {
local subst="
s|%PKGBASE%|$pkgbase|g
s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
"
# hack to allow specifying an initially nonexisting install file
@@ -131,12 +122,12 @@ _package() {
_package-headers() {
pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -200,7 +191,7 @@ _package-headers() {
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
@@ -209,9 +200,8 @@ _package-headers() {
_package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
mkdir -p "$builddir"