summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2020-01-26 13:25:40 +0000
committerLeonidas Spyropoulos2020-01-26 13:25:40 +0000
commit056aa4b178c78b0ff99468235282dc7cc9bd9b62 (patch)
tree9526ecfa6fc2d53e5de4a5a8c59c98001fa9fc83
parentf584d6f141d214124e35452fdeaf9d54f1246762 (diff)
downloadaur-056aa4b178c78b0ff99468235282dc7cc9bd9b62.tar.gz
upgpkg: linux-gc 5.4.15-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD44
2 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97f3cd7b28f4..82ab4cba6ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-gc
pkgdesc = Linux
- pkgver = 5.4.14
+ pkgver = 5.4.15
pkgrel = 1
url = https://cchalpha.blogspot.co.uk/
arch = x86_64
@@ -15,14 +15,14 @@ pkgbase = linux-gc
makedepends = imagemagick
makedepends = git
options = !strip
- source = linux-v5.4.14-arch1.tar.gz::https://git.archlinux.org/linux.git/snapshot/linux-v5.4.14-arch1.tar.gz
+ source = linux-v5.4.15-arch1.tar.gz::https://git.archlinux.org/linux.git/snapshot/linux-v5.4.15-arch1.tar.gz
source = config
source = 0001_bmq_v5.4-r2.patch::https://gitlab.com/alfredchen/bmq/raw/master/5.4/bmq_v5.4-r2.patch
source = 0002_enable_additional_cpu_optimizations-20190822.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20190822.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
- sha256sums = 1661feabd23e2823030488a200903643974dd6492467ca741e616d1d71a5ee3f
+ sha256sums = 0603a30a97480dea83edea04059b3a49b05cdfe767d95f3c3a90c65f237ff35e
sha256sums = 548d4588a491ba2bb7d53b6e3c59aa3fcf68a6d3465079607e4f1bee5add7016
sha256sums = 6a6a736cf1b3513d108bfd36f60baf50bb36b33aec21ab0d0ffad13602b7ff75
sha256sums = 8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5
@@ -34,11 +34,11 @@ pkgname = linux-gc
depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
- provides = linux-gc=5.4.14
+ provides = linux-gc=5.4.15
pkgname = linux-gc-headers
pkgdesc = Headers and scripts for building modules for the Linux kernel
depends = linux-gc
- provides = linux-gc-headers=5.4.14
- provides = linux-headers=5.4.14
+ provides = linux-gc-headers=5.4.15
+ provides = linux-headers=5.4.15
diff --git a/PKGBUILD b/PKGBUILD
index 9a0cbc9c40ed..d0edfab446de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-gc
-pkgver=5.4.14
+pkgver=5.4.15
pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver}-arch1
@@ -48,7 +48,7 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
-sha256sums=('1661feabd23e2823030488a200903643974dd6492467ca741e616d1d71a5ee3f'
+sha256sums=('0603a30a97480dea83edea04059b3a49b05cdfe767d95f3c3a90c65f237ff35e'
'548d4588a491ba2bb7d53b6e3c59aa3fcf68a6d3465079607e4f1bee5add7016'
'6a6a736cf1b3513d108bfd36f60baf50bb36b33aec21ab0d0ffad13602b7ff75'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5')
@@ -62,7 +62,7 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
- msg2 "Setting version..."
+ echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "$_kernelname" > localversion.20-pkgname
@@ -72,15 +72,15 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
+ echo "Applying patch $src..."
patch -Np1 < "../$src"
done
- msg2 "Setting config..."
+ echo "Setting config..."
cp ../config .config
# https://github.com/graysky2/kernel_gcc_patch
- msg2 "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
+ echo "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
make prepare
@@ -89,10 +89,10 @@ prepare() {
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
else
- msg2 "No modprobed.db data found"
+ echo "No modprobed.db data found"
exit
fi
fi
@@ -101,7 +101,7 @@ prepare() {
yes "" | make config >/dev/null
make -s kernelrelease > version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
+ echo "Prepared %s version %s" "$pkgbase" "$(<version)"
[[ -z "$_makenconfig" ]] || make nconfig
@@ -125,7 +125,7 @@ _package() {
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- msg2 "Installing boot image..."
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
@@ -133,13 +133,13 @@ _package() {
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- msg2 "Installing modules..."
+ echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -151,7 +151,7 @@ _package-headers() {
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
+ echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
@@ -164,7 +164,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- msg2 "Installing headers..."
+ echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -180,10 +180,10 @@ _package-headers() {
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
@@ -191,16 +191,16 @@ _package-headers() {
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ echo "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
@@ -215,11 +215,11 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
+ echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}