summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2020-06-12 11:15:15 +0100
committerLeonidas Spyropoulos2020-06-12 11:15:15 +0100
commitac602da8a4af0cc8c746882f78a293c9dcb9412c (patch)
tree31a3c370db0444979bbf77df08d8c15e9ab8a84a
parent40b3d78ced6b43029973b9a4e7b9ac4291561f2a (diff)
downloadaur-ac602da8a4af0cc8c746882f78a293c9dcb9412c.tar.gz
upgpkg: linux-gc 5.7.2-1
Remove DEBUG symbols during build
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c98b0d440035..13da72e17ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,6 @@ pkgbase = linux-gc
makedepends = bc
makedepends = kmod
makedepends = libelf
- makedepends = pahole
makedepends = xmlto
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
diff --git a/PKGBUILD b/PKGBUILD
index 223cff120519..5e98dbf2150c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ url="https://cchalpha.blogspot.co.uk/"
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole
+ bc kmod libelf
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
git
)
@@ -83,6 +83,11 @@ prepare() {
echo "Setting config..."
cp ../config .config
+ # disable CONFIG_DEBUG_INFO=y at build time introduced in this commit
+ # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
+ sed -i -e 's/CONFIG_DEBUG_INFO=y/# CONFIG_DEBUG_INFO is not set/' \
+ -i -e '/CONFIG_DEBUG_INFO_DWARF4=y/d' -i -e '/CONFIG_DEBUG_INFO_BTF=y/d' ./.config
+
echo "Applying patch ${_bmq_patch}..."
patch -Np1 -i "$srcdir/${_bmq_patch}"
@@ -142,7 +147,9 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ #make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ # not needed since not building with CONFIG_DEBUG_INFO=y
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -223,8 +230,9 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- echo "Stripping vmlinux..."
- strip -v $STRIP_STATIC "$builddir/vmlinux"
+ #echo "Stripping vmlinux..."
+ #strip -v $STRIP_STATIC "$builddir/vmlinux"
+ # not needed since not building with CONFIG_DEBUG_INFO=y
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"