aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cohen2023-05-15 23:18:24 -0500
committerDavid Cohen2023-05-15 23:20:15 -0500
commit989b630726cb0c795700d92075d15f9e9a5b2ad1 (patch)
treee6c6712ec7a2c6f13ac53c0898db460e87121958
parentf59368a6cd489c8e28777e64a8ee01b04efdcea0 (diff)
downloadaur-989b630726cb0c795700d92075d15f9e9a5b2ad1.tar.gz
IGNORE_USER_CUSTOM env variable will make PKGBUILD ignore user customizations
Signed-off-by: David Cohen <dacohen@pm.me>
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD22
-rw-r--r--README4
3 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6071f79136a1..41a559543b4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,19 @@
pkgbase = linux-git
pkgdesc = Linus Torvalds' Mainline Linux
- pkgver = v6.4.rc1.r109.cc3c44c9fda2
+ pkgver = v6.4.rc2.r0.f1fcbaa18b28
pkgrel = 1
url = https://www.kernel.org
arch = x86_64
license = GPL2
makedepends = bc
+ makedepends = cpio
+ makedepends = gettext
+ makedepends = git
makedepends = libelf
makedepends = pahole
- makedepends = cpio
makedepends = perl
makedepends = tar
makedepends = xz
- makedepends = gettext
- makedepends = xmlto
- makedepends = python-sphinx
- makedepends = python-sphinx_rtd_theme
- makedepends = graphviz
- makedepends = imagemagick
- makedepends = git
options = !strip
backup = etc/linux-git/config
backup = etc/linux-git/remote
@@ -31,24 +26,24 @@ pkgbase = linux-git
source = patches
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = SKIP
- sha256sums = 6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da
- sha256sums = 6e41a729c2f2946d3606ca2c0cb3a058c9700b0f73110eed36dcba91a271e50f
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 986e39ee1cb41d342b19f1c5af8016d48afa1e182237dbdcc3f222ae4203ef2d
+ b2sums = SKIP
+ b2sums = e4998c4a144843cb6072ffc706baae3cf7530fc245fbf9cc4264aad119304944bdbb5aed9e5cfcefc87ab3e694067759e400dda669d5d734c439db288ad467c1
+ b2sums = 249bec61fed688345a0f41245af9e8e189af3149e66a3c0dcc8e833151428232a701a35ed760ef93ceb5f25d9378c44f903f380a7051a65fb9a203c6fb51ebcd
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = a483bfcc2f7926def88842a1b5da5170ed50e941d82e5389521c71e82015f1b1d8503efda1517f85105a5ed218bd4ca282f4381b16926cdc774c85b8b5a11615
pkgname = linux-git
pkgdesc = The Linus Torvalds' Mainline Linux kernel and modules
install = linux-git.install
depends = coreutils
- depends = kmod
depends = initramfs
+ depends = kmod
optdepends = wireless-regdb: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
+ provides = KSMBD-MODULE
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- provides = KSMBD-MODULE
replaces = virtualbox-guest-modules-arch
replaces = wireguard-arch
diff --git a/PKGBUILD b/PKGBUILD
index 668c6788be7e..6160331cc1be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# will be on config.extra file.
pkgbase=linux-git
-pkgver=v6.3.1.r0.a83b81b7392d.patched.stable.linux
+pkgver=v6.4.rc2.r0.f1fcbaa18b28
pkgrel=1
pkgdesc="Linus Torvalds' Mainline Linux"
url="https://www.kernel.org"
@@ -76,7 +76,9 @@ pkgver() {
prepare() {
cd $_srcname
- [[ -f "$_userremote" ]] && source "$_userremote" || source "../${_userremote##*/}"
+ if [[ -z ${IGNORE_USER_CUSTOM} ]]; then
+ [[ -f "$_userremote" ]] && source "$_userremote" || source "../${_userremote##*/}"
+ fi
if [[ -n "$REMOTE" && -n "$COMMIT" ]]; then
REMOTE_PREFIX=${source[0]##${_srcname}::git+}
REMOTE_PREFIX=${REMOTE_PREFIX%%torvalds/linux}
@@ -110,7 +112,9 @@ prepare() {
patch -Np1 < "../$src"
done
- [[ -f "$_userpatches" ]] && source "$_userpatches"
+ if [[ -z ${IGNORE_USER_CUSTOM} ]]; then
+ [[ -f "$_userpatches" ]] && source "$_userpatches"
+ fi
PATCHES_PREFIX=${_userpatches%%patches}
_USER_PATCHES="0"
for src in "${PATCHES}"; do
@@ -121,14 +125,16 @@ prepare() {
done
# Let user see the patches were applied before proceed with the build
- [[ ${_USER_PATCHES} = "1" ]] && sleep 2
+ [[ ${_USER_PATCHES} = "1" ]] && sleep 5
echo "Setting config..."
cat ../config ../config.extra > .config
- if [[ -f "$_userconfig" ]]; then
- cat $_userconfig >> .config
- else
- cat ../config.user >> .config
+ if [[ -z ${IGNORE_USER_CUSTOM} ]]; then
+ if [[ -f "$_userconfig" ]]; then
+ cat $_userconfig >> .config
+ else
+ cat ../config.user >> .config
+ fi
fi
_make olddefconfig
diff -u ../config .config || :
diff --git a/README b/README
index c8f9c846faeb..c35986563340 100644
--- a/README
+++ b/README
@@ -18,3 +18,7 @@ case using the current Linux mainline is not desired:
installation, you can copy the patches to the directory
/etc/linux-git/patches and follow the instructions included on
/etc/linux-git/patches/patches file.
+
+Set env variable IGNORE_USER_CUSTOM to build package ignoring current
+customizations in place:
+$ IGNORE_USER_CUSTOM=1 makepkg