aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2020-10-30 20:37:43 +0000
committerJonathan Wright2020-10-30 20:37:43 +0000
commitf2499f86c85283abebd068ba65845b6ab84d5f48 (patch)
tree8a6ffab89f21245d671cfe640ec314b1143e03d8
parent924616e35ecc2968fbf2f93cd1ff8b0694ed7325 (diff)
downloadaur-f2499f86c85283abebd068ba65845b6ab84d5f48.tar.gz
Add stripping to build and install stages
Following the inclusion of CONFIG_DEBUG_INFO as part of the copy of the 5.9.x configuration, the setting of INSTALL_MOD_STRIP was not copied across. The stripping of modules during the make, and run strip on the vmlinuz binary as well (both taken from the current PKGBUILD for 5.9.2).
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 214ed749fda9..5c29fc9e5218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -78,7 +78,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -157,6 +157,9 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"