summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Novosyolov2015-09-22 09:47:07 +0300
committerAnton Novosyolov2015-09-22 09:47:07 +0300
commit19a6e415d5bf06a73f63fd911009a9f2a35d70ad (patch)
tree6cb049195a19f4dd81421f99673871e29471d064
parentc29b0ba7aa05cdb7fc21413e7e66955839e88ad2 (diff)
downloadaur-19a6e415d5bf06a73f63fd911009a9f2a35d70ad.tar.gz
4.2.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b521b799319..874bcc8f1371 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-ice
pkgdesc = The Linux-ice kernel and modules
- pkgver = 4.2
+ pkgver = 4.2.1
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -14,6 +14,8 @@ pkgbase = linux-ice
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.1.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.2.1.sign
source = config
source = config.x86_64
source = linux.preset
@@ -26,6 +28,8 @@ pkgbase = linux-ice
source = 0001-fix-bridge-regression.patch
sha256sums = cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb
sha256sums = SKIP
+ sha256sums = 9d0ab6525eb5f42056e2465267c62fa67efc75c57ad5345b99414b783278e9a3
+ sha256sums = SKIP
sha256sums = a0c3f8fc64651eb3e28a48c7e74287716bc0a215db5fa7deda1b5c1e3cadf878
sha256sums = 956bba07f86e8f6e29deb1d0768f71b1bbcaebc39358083fecef2ad6448f46e6
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
@@ -45,23 +49,23 @@ pkgname = linux-ice
depends = kmod
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
- provides = kernel26-ice=4.2
- provides = linux=4.2
+ provides = kernel26-ice=4.2.1
+ provides = linux=4.2.1
conflicts = kernel26-ice
replaces = kernel26-ice
backup = etc/mkinitcpio.d/linux-ice.preset
pkgname = linux-ice-headers
pkgdesc = Header files and scripts for building modules for Linux-ice kernel
- provides = kernel26-ice-headers=4.2
- provides = linux-headers=4.2
+ provides = kernel26-ice-headers=4.2.1
+ provides = linux-headers=4.2.1
conflicts = kernel26-ice-headers
replaces = kernel26-ice-headers
pkgname = linux-ice-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-ice kernel
- provides = kernel26-ice-docs=4.2
- provides = linux-docs=4.2
+ provides = kernel26-ice-docs=4.2.1
+ provides = linux-docs=4.2.1
conflicts = kernel26-ice-docs
replaces = kernel26-ice-docs
diff --git a/PKGBUILD b/PKGBUILD
index 16332f58ea16..70835603ab83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-ice # Build kernel with a different name
_srcname=linux-4.2
-pkgver=4.2
+pkgver=4.2.1
pkgrel=1
_toipatch=tuxonice-for-linux-4.2.0-2015-09-08.patch
arch=('i686' 'x86_64')
@@ -15,8 +15,8 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -32,6 +32,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
sha256sums=('cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb'
'SKIP'
+ '9d0ab6525eb5f42056e2465267c62fa67efc75c57ad5345b99414b783278e9a3'
+ 'SKIP'
'a0c3f8fc64651eb3e28a48c7e74287716bc0a215db5fa7deda1b5c1e3cadf878'
'956bba07f86e8f6e29deb1d0768f71b1bbcaebc39358083fecef2ad6448f46e6'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
@@ -53,7 +55,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git