summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Novosyolov2015-12-25 10:38:14 +0300
committerAnton Novosyolov2015-12-25 10:38:14 +0300
commitfbd196a9e3fe381d2eaeddee222512a262ddaafa (patch)
treedfd1685e96269df7cdc62885c183599a7b6acf59
parente0fb1603e13d45257b0e39a73736ad7f6a079b83 (diff)
downloadaur-fbd196a9e3fe381d2eaeddee222512a262ddaafa.tar.gz
4.3.3-2
-rw-r--r--.SRCINFO8
-rw-r--r--0001-disabling-primary-plane-in-the-noatomic-case.patch56
-rw-r--r--PKGBUILD12
3 files changed, 70 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f122cbee61d..db21d2dcea40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-ice
pkgdesc = The Linux-ice kernel and modules
pkgver = 4.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = i686
arch = x86_64
@@ -16,22 +16,24 @@ pkgbase = linux-ice
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.3.tar.sign
source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.3.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.3.3.sign
+ source = 0001-disabling-primary-plane-in-the-noatomic-case.patch
source = config
source = config.x86_64
source = linux.preset
source = linux.install
source = change-default-console-loglevel.patch
- source = http://tuxonice.net/downloads/all/tuxonice-for-linux-head-4.3.0-2015-11-07.patch.bz2
+ source = http://tuxonice.net/downloads/all/tuxonice-for-linux-4.3.3-2015-12-18.patch.bz2
sha256sums = 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae
sha256sums = SKIP
sha256sums = 95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5
sha256sums = SKIP
+ sha256sums = abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d
sha256sums = 5d9d7aefa33b239279456fa8a8cd4de2d9ee4601f9f432b718c9bfdb7ce2925b
sha256sums = 8c1ba876b2291c58269f7232b291e369daa925ba904b45636af4e80c0f73ced5
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 8c270194a0ab5deea628880f42443dff0932d445f1aa6aec6a295924a18b7643
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
- sha256sums = 1d52d29e88235511bfae5f105c5d6d02fc1a1864a1050c4133a452d0fbf8d7c2
+ sha256sums = 7b82218d17001ab54691552fd87f38482afa4a2923cfdab104381ca0efce8ae0
pkgname = linux-ice
pkgdesc = The Linux-ice kernel and modules
diff --git a/0001-disabling-primary-plane-in-the-noatomic-case.patch b/0001-disabling-primary-plane-in-the-noatomic-case.patch
new file mode 100644
index 000000000000..241b1012e02e
--- /dev/null
+++ b/0001-disabling-primary-plane-in-the-noatomic-case.patch
@@ -0,0 +1,56 @@
+From 634b3a4a476e96816d5d6cd5bb9f8900a53f56ba Mon Sep 17 00:00:00 2001
+From: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
+Date: Mon, 23 Nov 2015 10:25:28 +0100
+Subject: drm/i915: Do a better job at disabling primary plane in the noatomic
+ case.
+
+When disable_noatomic is called plane_mask is not correct yet, and
+plane_state->visible = true is left as true after disabling the primary
+plane.
+
+Other planes are already disabled as part of crtc sanitization, only the
+primary is left active. But the plane_mask is not updated here. It gets
+updated during fb takeover in modeset_gem_init, or set to the new value
+on resume.
+
+This means that to disable the primary plane 1 << drm_plane_index(primary)
+needs to be used.
+
+Afterwards because the crtc is no longer active it's forbidden to keep
+plane_state->visible set, or a WARN_ON in
+intel_plane_atomic_calc_changes triggers. There are other code points
+that rely on accurate plane_state->visible too, so make sure the bool is
+cleared.
+
+The other planes are already disabled in intel_sanitize_crtc, so they
+don't have to be handled here.
+
+Cc: stable@vger.kernel.org #v4.3, v4.2?
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=92655
+Tested-by: Tomas Mezzadra <tmezzadra@gmail.com>
+Signed-off-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
+Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
+Link: http://patchwork.freedesktop.org/patch/msgid/5652DB88.9070208@linux.intel.com
+(cherry picked from commit 54a4196188eab82e6f0a5f05716626e9f18b8fb6)
+Signed-off-by: Jani Nikula <jani.nikula@intel.com>
+
+diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
+index 22e86d2..62211ab 100644
+--- a/drivers/gpu/drm/i915/intel_display.c
++++ b/drivers/gpu/drm/i915/intel_display.c
+@@ -6309,9 +6309,11 @@ static void intel_crtc_disable_noatomic(struct drm_crtc *crtc)
+ if (to_intel_plane_state(crtc->primary->state)->visible) {
+ intel_crtc_wait_for_pending_flips(crtc);
+ intel_pre_disable_primary(crtc);
++
++ intel_crtc_disable_planes(crtc, 1 << drm_plane_index(crtc->primary));
++ to_intel_plane_state(crtc->primary->state)->visible = false;
+ }
+
+- intel_crtc_disable_planes(crtc, crtc->state->plane_mask);
+ dev_priv->display.crtc_disable(crtc);
+ intel_crtc->active = false;
+ intel_update_watermarks(crtc);
+--
+cgit v0.10.2
+
diff --git a/PKGBUILD b/PKGBUILD
index d1d94919175d..8e1688a084b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgbase=linux-ice # Build kernel with a different name
_srcname=linux-4.3
pkgver=4.3.3
-pkgrel=1
-_toipatch=tuxonice-for-linux-head-4.3.0-2015-11-07.patch
+pkgrel=2
+_toipatch=tuxonice-for-linux-4.3.3-2015-12-18.patch
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -17,6 +17,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "0001-disabling-primary-plane-in-the-noatomic-case.patch"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -30,12 +31,13 @@ sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'SKIP'
'95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5'
'SKIP'
+ 'abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d'
'5d9d7aefa33b239279456fa8a8cd4de2d9ee4601f9f432b718c9bfdb7ce2925b'
'8c1ba876b2291c58269f7232b291e369daa925ba904b45636af4e80c0f73ced5'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'8c270194a0ab5deea628880f42443dff0932d445f1aa6aec6a295924a18b7643'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '1d52d29e88235511bfae5f105c5d6d02fc1a1864a1050c4133a452d0fbf8d7c2')
+ '7b82218d17001ab54691552fd87f38482afa4a2923cfdab104381ca0efce8ae0')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -60,6 +62,10 @@ prepare() {
# tuxonice patch
patch -p1 -i "${srcdir}/${_toipatch}"
+ # fix #46968
+ # hangs on older intel hardware
+ patch -Np1 -i "${srcdir}/0001-disabling-primary-plane-in-the-noatomic-case.patch"
+
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else