summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado2016-03-27 21:39:47 -0300
committerAndré Fabian Silva Delgado2016-03-27 21:39:47 -0300
commit72e352618a440665daeac7acbe9e1d55aa4a6d53 (patch)
tree742c14bc7020f84e6cace696fc0a73cd0c52fc12
parent808ed9d5856c9e7241bc521b03bc12d76ac28ceb (diff)
downloadaur-72e352618a440665daeac7acbe9e1d55aa4a6d53.tar.gz
Update to 4.5_gnu-1.1
* disable CONFIG_LIBIPW since it's just useful for CONFIG_IPW2100 and CONFIG_IPW2200 that are modules for Intel PRO/Wireless devices -> https://labs.parabola.nu/issues/47 * fix Atmel maXTouch touchscreen support -> https://labs.parabola.nu/issues/877
-rw-r--r--.SRCINFO12
-rw-r--r--0003-fix-atmel-maxtouch-touchscreen-support.patch13
-rw-r--r--PKGBUILD15
-rw-r--r--config.armv7h4
-rw-r--r--config.i6864
-rw-r--r--config.x86_647
6 files changed, 34 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab434b2f4879..f9797ab6d41d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 16 05:36:46 UTC 2016
+# Mon Mar 28 00:39:37 UTC 2016
pkgbase = linux-libre
pkgver = 4.5_gnu
- pkgrel = 1
+ pkgrel = 1.1
url = http://linux-libre.fsfla.org/
arch = i686
arch = x86_64
@@ -29,6 +29,7 @@ pkgbase = linux-libre
source = change-default-console-loglevel.patch
source = 0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch
source = 0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch
+ source = 0003-fix-atmel-maxtouch-touchscreen-support.patch
source = https://repo.parabola.nu/other/rcn-libre/patches/4.5/rcn-libre-4.5-armv7-x2.patch
source = https://repo.parabola.nu/other/rcn-libre/patches/4.5/rcn-libre-4.5-armv7-x2.patch.sig
source = 0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
@@ -47,13 +48,14 @@ pkgbase = linux-libre
sha256sums = SKIP
sha256sums = 6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a
sha256sums = SKIP
- sha256sums = 5009a4877d8435a544a746663edc6d254e4bc3a8b21e4ae4f9718bf9e5f43310
- sha256sums = 9f37490091ca6c0a431feb098ba4b567e5b75eed402701e06c8e366e07e34ee2
- sha256sums = 929fdac93589dc50ca33f7b409de82e1c85b28075e962cf1ccd46f980ce7a162
+ sha256sums = 40eadc1b5f9d11b4cd183491973c866d5fd96c15f75f0a82af52d0ae170948cd
+ sha256sums = 668df07cc6664ec056365702c7554bad1182460e80b3705bfd5d12283b6ed499
+ sha256sums = 0f830583294bdf445ed1cef604874f5e98e4f71e69a19e2227cdd2b26c3a3274
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = 93edfa289033e491ba7f9d6886943ce68c94fb45dc6817a3fc577c7ba6c369d6
sha256sums = 3d3266bd082321dccf429cc2200d1a4d870d2031546f9f591b6dfbb698294808
+ sha256sums = 0a6f76bbc03ae6e846a4ba4e31bbc0a40b1ae538c1271defcbe3089e00a4b53d
sha256sums = 9865a47b50ccab0993f9b371f45b526162307fffc67dfadcae6fae31d05a67b9
sha256sums = SKIP
sha256sums = abc20251d9becc566e46ff0fca77074eca9de5d119d2dbccb7d9c933b2d59979
diff --git a/0003-fix-atmel-maxtouch-touchscreen-support.patch b/0003-fix-atmel-maxtouch-touchscreen-support.patch
new file mode 100644
index 000000000000..9d2444252a94
--- /dev/null
+++ b/0003-fix-atmel-maxtouch-touchscreen-support.patch
@@ -0,0 +1,13 @@
+diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscreen/atmel_mxt_ts.c
+index 726a83e..d818834 100644
+--- a/drivers/input/touchscreen/atmel_mxt_ts.c
++++ b/drivers/input/touchscreen/atmel_mxt_ts.c
+@@ -1989,7 +1989,7 @@ static int mxt_initialize(struct mxt_data *data)
+ if (error)
+ goto err_free_object_table;
+
+- error = reject_firmware_nowait(THIS_MODULE, true, MXT_CFG_NAME,
++ error = request_firmware_nowait(THIS_MODULE, true, MXT_CFG_NAME,
+ &client->dev, GFP_KERNEL, data,
+ mxt_config_cb);
+ if (error) {
diff --git a/PKGBUILD b/PKGBUILD
index 86ff43d2d59c..2af88537ff6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _replacesoldmodules=() # '%' gets replaced with _kernelname
_srcname=linux-${_pkgbasever%-*}
_archpkgver=${_pkgver%-*}
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=1.1
rcnrel=armv7-x2
arch=('i686' 'x86_64' 'armv7h')
url="http://linux-libre.fsfla.org/"
@@ -47,6 +47,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'change-default-console-loglevel.patch'
'0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch'
'0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch'
+ '0003-fix-atmel-maxtouch-touchscreen-support.patch'
# armv7h patches
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch"
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch.sig"
@@ -66,13 +67,14 @@ sha256sums=('c37a135518d5a69b26bae8441bc20e5a5ea87d3228cfe72f75a714cff730a84e'
'SKIP'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- '5009a4877d8435a544a746663edc6d254e4bc3a8b21e4ae4f9718bf9e5f43310'
- '9f37490091ca6c0a431feb098ba4b567e5b75eed402701e06c8e366e07e34ee2'
- '929fdac93589dc50ca33f7b409de82e1c85b28075e962cf1ccd46f980ce7a162'
+ '40eadc1b5f9d11b4cd183491973c866d5fd96c15f75f0a82af52d0ae170948cd'
+ '668df07cc6664ec056365702c7554bad1182460e80b3705bfd5d12283b6ed499'
+ '0f830583294bdf445ed1cef604874f5e98e4f71e69a19e2227cdd2b26c3a3274'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'93edfa289033e491ba7f9d6886943ce68c94fb45dc6817a3fc577c7ba6c369d6'
'3d3266bd082321dccf429cc2200d1a4d870d2031546f9f591b6dfbb698294808'
+ '0a6f76bbc03ae6e846a4ba4e31bbc0a40b1ae538c1271defcbe3089e00a4b53d'
'9865a47b50ccab0993f9b371f45b526162307fffc67dfadcae6fae31d05a67b9'
'SKIP'
'abc20251d9becc566e46ff0fca77074eca9de5d119d2dbccb7d9c933b2d59979'
@@ -144,6 +146,11 @@ prepare() {
# http://www.coreboot.org/EHCI_Gadget_Debug
patch -p1 -i "${srcdir}/0002-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch"
+ # fix Atmel maXTouch touchscreen support
+ # https://labs.parabola.nu/issues/877
+ # http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
+ patch -p1 -i "${srcdir}/0003-fix-atmel-maxtouch-touchscreen-support.patch"
+
cat "${srcdir}/config.${CARCH}" > ./.config
# append pkgrel to extraversion
diff --git a/config.armv7h b/config.armv7h
index 6f7762e427ff..2a1b9260033d 100644
--- a/config.armv7h
+++ b/config.armv7h
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.5.0-gnu Kernel Configuration
+# Linux/arm 4.5.0-gnu-1 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@@ -2866,8 +2866,6 @@ CONFIG_WLAN_VENDOR_CISCO=y
CONFIG_WLAN_VENDOR_INTEL=y
# CONFIG_IPW2100 is not set
# CONFIG_IPW2200 is not set
-CONFIG_LIBIPW=m
-# CONFIG_LIBIPW_DEBUG is not set
CONFIG_IWLEGACY=m
CONFIG_IWL4965=m
CONFIG_IWL3945=m
diff --git a/config.i686 b/config.i686
index eaf2a26e5257..7f229c65792e 100644
--- a/config.i686
+++ b/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.5.0-gnu Kernel Configuration
+# Linux/x86 4.5.0-gnu-1 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -2899,8 +2899,6 @@ CONFIG_AIRO_CS=m
CONFIG_WLAN_VENDOR_INTEL=y
# CONFIG_IPW2100 is not set
# CONFIG_IPW2200 is not set
-CONFIG_LIBIPW=m
-# CONFIG_LIBIPW_DEBUG is not set
CONFIG_IWLEGACY=m
CONFIG_IWL4965=m
CONFIG_IWL3945=m
diff --git a/config.x86_64 b/config.x86_64
index a6d466bad4bb..4b4047f90afd 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.5.0-gnu Kernel Configuration
+# Linux/x86 4.5.0-gnu-1 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
@@ -2836,13 +2836,8 @@ CONFIG_WLAN_VENDOR_CISCO=y
CONFIG_AIRO=m
CONFIG_AIRO_CS=m
CONFIG_WLAN_VENDOR_INTEL=y
-CONFIG_IPW2100=m
-CONFIG_IPW2100_MONITOR=y
-# CONFIG_IPW2100_DEBUG is not set
# CONFIG_IPW2100 is not set
# CONFIG_IPW2200 is not set
-CONFIG_LIBIPW=m
-# CONFIG_LIBIPW_DEBUG is not set
CONFIG_IWLEGACY=m
CONFIG_IWL4965=m
CONFIG_IWL3945=m