aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2012-07-20 20:33:58 -0700
committeryar2015-07-03 16:58:15 -0700
commit49da9530ff57c4fe20c86927dc35db0b0ed2aaf1 (patch)
tree5e0684f98a3a898c08ae3b9c32ece62691cc446e
parent0442e1ff33b09c9b676cd36bf02de993035730d0 (diff)
downloadaur-49da9530ff57c4fe20c86927dc35db0b0ed2aaf1.tar.gz
bump 3.4.6, grub conflict, update README
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--README42
-rw-r--r--config.x86_642
-rw-r--r--linux-linode.install2
5 files changed, 28 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25d7ccda8b27..7dffd5818443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux
pkgdesc = The Linux Kernel and modules
- pkgver = 3.4.5
+ pkgver = 3.4.6
pkgrel = 1
url = http://www.kernel.org/
install = linux-linode.install
@@ -16,19 +16,21 @@ pkgbase = linux
provides = linux
conflicts = kernel26
conflicts = linux
+ conflicts = grub
+ conflicts = grub-legacy
replaces = kernel26
replaces = linux
options = !strip
backup = etc/mkinitcpio.d/linux-linode.preset
source = http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.4.tar.xz
- source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.4.5.xz
+ source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.4.6.xz
source = config.x86_64
source = menu.lst
source = linux-linode.preset
source = change-default-console-loglevel.patch
md5sums = cba7741056c05ac98277b99909039a7e
- md5sums = e60f1d8032069d091f3692c1d7a89b8b
- md5sums = 88a500cfb6f34476679bf897059d43c8
+ md5sums = 14443e53d3ab88e6eac45d954d891e00
+ md5sums = e4d414895dca61fc6003991050b4cd92
md5sums = 4c45d442db6239f0b3d0008c0a17c76c
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
diff --git a/PKGBUILD b/PKGBUILD
index b6bb472b450f..68d82b3040b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgbase=linux
pkgname=linux-linode
_kernelname=${pkgname#linux}
_basekernel=3.4
-pkgver=${_basekernel}.5
+pkgver=${_basekernel}.6
pkgrel=1
arch=(x86_64)
url="http://www.kernel.org/"
@@ -16,15 +16,15 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.4.tar.xz"
"${pkgname}.preset"
'change-default-console-loglevel.patch')
md5sums=('cba7741056c05ac98277b99909039a7e'
- 'e60f1d8032069d091f3692c1d7a89b8b'
- '88a500cfb6f34476679bf897059d43c8'
+ '14443e53d3ab88e6eac45d954d891e00'
+ 'e4d414895dca61fc6003991050b4cd92'
'4c45d442db6239f0b3d0008c0a17c76c'
'ee66f3cd0c5bc0ba0f65499784d19f30'
'9d3c56a4b999c8bfbd4018089a62f662')
pkgdesc="The Linux Kernel and modules"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
provides=(kernel26 linux)
-conflicts=(kernel26 linux)
+conflicts=(kernel26 linux grub grub-legacy)
replaces=(kernel26 linux)
backup=(etc/mkinitcpio.d/${pkgname}.preset)
install=${pkgname}.install
diff --git a/README b/README
index b93aa0cd7ed9..7ea109b8ad0a 100644
--- a/README
+++ b/README
@@ -1,31 +1,21 @@
-Linode (http://www.linode.com) is a VPS host with very neat,
-very scriptable server-managing software, which supports
-Arch Linux servers and custom kernels. This project maintains
-the PKGBUILD for an Arch package (installable with pacman)
-containing a kernel that is super-optimized for running on a
-Linode instance, and also the grub menu to boot from it.
+Linode (http://www.linode.com) is a VPS host which supports Arch Linux servers
+and custom kernels. This project gives you an Arch kernel for your Linode.
-Optimizations include compiling for Linode's exact cpu type and
-stripping out all code for hardware that does not exist on Linode,
-i.e. almost everything but the virtual xen block devices, NICs and
-console. I also removed almost all filesystem support as 99% of
-you will just be using their ext3 image and the other 1% will want
-to tweak things anyway.
+linux-linode is designed to closely track Arch kernel development while being as
+resource friendly as possible. Compiles specifically for Linode's CPUs and
+removes unneeded hardware support (i.e. almost everything besides xen block dev,
+NICs & console). Also defaults to removing all filesystems but ext3 and
+compiling in many things that are usually modules (fuse, dm-crypt for example)
+but you can of course nconfig whatever you want. :)
-To build this package on any arch linux machine, just do this:
+Includes a grub boot menu where Linode expects to find it. You do NOT need grub,
+grub2, grub-legacy or any other. grub-legacy is a conflict because of menu.lst.
-* git clone git@github.com:twomen/linux-linode.git ~/linux-linode
-* cd ~/linux-linode
-* makepkg -c
+This is a 64-bit kernel, so make sure you're using their 64-bit Arch image!
-This will give you a file like: linux-linode-3.0.1-1-x86_64.pkg.tar.xz
+Steps to use:
-In order to use this super-optimized kernel on your linode, just do this:
-
-* Make sure you have the 64-bit Arch image (2010-05 at time of writing)
-* pacman -Syu (just to make sure, the image is really old...)
-* Upload pkg file to server
-* sudo pacman -U /path/to/linux-linode-*.pkg.tar.xz
-* set your linode kernel to pv-grub-64
-* reboot
-* tell me about any bugs that were my fault :D
+ 1) pacman -Syu
+ 2) pacman -U /path/to/linux-linode-*-x86_64.pkg.tar.xz
+ 3) reboot your Linode with "kernel" set to: pv-grub-x86_64
+ 4) report bugs ;)
diff --git a/config.x86_64 b/config.x86_64
index f9ad4db1f41f..6535497ded65 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.4.5-1 Kernel Configuration
+# Linux/x86_64 3.4.6-1 Kernel Configuration
#
CONFIG_64BIT=y
# CONFIG_X86_32 is not set
diff --git a/linux-linode.install b/linux-linode.install
index c22da47794c9..8d2bcca393eb 100644
--- a/linux-linode.install
+++ b/linux-linode.install
@@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-linode
-KERNEL_VERSION=3.4.5-1-linode
+KERNEL_VERSION=3.4.6-1-linode
export PATH='/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'