aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2015-08-30 13:13:46 -0700
committeryar2015-08-30 13:13:46 -0700
commit72b0c8d8cd44fad4d4b66eb0ce3bbbf4abd8f24b (patch)
treeafc0f11bf08f510ef0b5e996014734b8b9c86c98
parent47dce9f8443ea5b80bb7bece40e25fbbbd1a7173 (diff)
downloadaur-72b0c8d8cd44fad4d4b66eb0ce3bbbf4abd8f24b.tar.gz
bump 4.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc3f008fe678..e71d98f8ae35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-linode
pkgdesc = Kernel for Linode servers
- pkgver = 4.1.5
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/yardenac/linux-linode
install = install
@@ -23,17 +23,13 @@ pkgbase = linux-linode
options = !strip
backup = etc/mkinitcpio.d/linux-linode.preset
backup = boot/grub/menu.lst
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.5.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.5.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.2.tar.sign
source = config
source = config.x86_64
source = menu.lst
source = preset
- sha512sums = 168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0
- sha512sums = SKIP
- sha512sums = 1325cdb35ea1f277d513932af37804f788b96ae63b94cedeb3c9b916ee8963bbd6aca5d0e13279e36a81f1de06005c5f3666ecfc845609932686f261fa4250c5
+ sha512sums = a87bbce3c0c6d810a41bbba1c0dcaae80dc38dded9f8571e97fa4ee5a468d655daf52d260911412f7c7da3171a5114e89d63da14b1753b9a3eb2cc38fd89b9ee
sha512sums = SKIP
sha512sums = 37b461f797c69fbc4a53eb18430821f6e7b11d50dc0a59de02d0760a943b1f7d10b5743d6b3d6fc96761988a60ceda6c1a256e06bfe2da8fb261a423debc2278
sha512sums = cbd765bc39c4b09a0e9ed4bbfcd18b48f2916a1b5fe5ecc05a3b9339e39f65199708793971566724e4bd23010a4f8f5c45026f6708055d7e0b4962259240ecbd
diff --git a/PKGBUILD b/PKGBUILD
index f975371f4b38..aedaf49b3efc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# tracks: https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
pkgname=linux-linode
-_basekernel=4.1
+_basekernel=4.2
_kernelname=${pkgname#linux}
_srcname=linux-${_basekernel}
-pkgver=${_basekernel}.6
+pkgver=${_basekernel}.0
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/yardenac/linux-linode"
@@ -13,13 +13,12 @@ license=(GPL2)
makedepends=(xmlto docbook-xsl kmod inetutils bc 'gcc>=4.9.0')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar."{xz,sign}
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}."{xz,sign}
+# "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}."{xz,sign}
'config'
'config.x86_64'
'menu.lst'
'preset')
-sha512sums=('168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0' 'SKIP'
- '1b725c2051d7dd9129c927fdb90d8d7a2e13149a2dd1175c5efacfc516e664af3647bca83d847197f8c19ef140bf07ea856868e27bef4a1cad9607e40b527424' 'SKIP'
+sha512sums=('a87bbce3c0c6d810a41bbba1c0dcaae80dc38dded9f8571e97fa4ee5a468d655daf52d260911412f7c7da3171a5114e89d63da14b1753b9a3eb2cc38fd89b9ee' 'SKIP'
'37b461f797c69fbc4a53eb18430821f6e7b11d50dc0a59de02d0760a943b1f7d10b5743d6b3d6fc96761988a60ceda6c1a256e06bfe2da8fb261a423debc2278'
'cbd765bc39c4b09a0e9ed4bbfcd18b48f2916a1b5fe5ecc05a3b9339e39f65199708793971566724e4bd23010a4f8f5c45026f6708055d7e0b4962259240ecbd'
'810e1e1cd67b172f29db6c1a3caed8050bb3ff86db1d49abcebd76b5ea70622deefb587cc914d1819df78525ce433564f71533822244a286373fc0f7605e6dde'
@@ -37,7 +36,7 @@ install=install
prepare() {
cd "${srcdir}/${_srcname}"
- patch -p1 -i "${srcdir}/patch-${pkgver}"
+# patch -p1 -i "${srcdir}/patch-${pkgver}"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else