aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubba Reduppa2011-08-11 22:44:09 -0700
committeryar2015-07-03 16:58:12 -0700
commit8b150b43d276c827b6f591aa5559541be5d9bc61 (patch)
tree8a5c97c9d82b18af5b735a37ce3f48847bd23acb
parent649bfd82414ecb1a1a12aafa471284aeff3eb7a5 (diff)
downloadaur-8b150b43d276c827b6f591aa5559541be5d9bc61.tar.gz
bug fixes, legacy_pty support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--config.x86_643
-rwxr-xr-xnconfig-wrapper13
4 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56080cfaf427..034bbca71427 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-linode
pkgdesc = The Linux Kernel and modules
pkgver = 3.0.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.kernel.org/
install = linux-linode.install
arch = x86_64
@@ -28,7 +28,7 @@ pkgbase = linux-linode
source = change-default-console-loglevel.patch
md5sums = 398e95866794def22b12dfbc15ce89c0
md5sums = ac49f7907f1fc85fbab92d0f1aa1552a
- md5sums = bca869ad467d5ae0e849c75e5703ee40
+ md5sums = b073fa78b6eadca078382f3cae57452d
md5sums = 4f57cec4177ff365dfdf5457b3ed3136
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
diff --git a/PKGBUILD b/PKGBUILD
index 2e0437e3be0b..29aa4e182799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgname=linux-linode
_kernelname=-linode
_basekernel=3.0
pkgver=${_basekernel}.1
-pkgrel=5
+pkgrel=6
arch=(x86_64)
url="http://www.kernel.org/"
license=(GPL2)
@@ -16,7 +16,7 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-${_basekernel}.tar.bz2
'change-default-console-loglevel.patch')
md5sums=('398e95866794def22b12dfbc15ce89c0'
'ac49f7907f1fc85fbab92d0f1aa1552a'
- 'bca869ad467d5ae0e849c75e5703ee40'
+ 'b073fa78b6eadca078382f3cae57452d'
'4f57cec4177ff365dfdf5457b3ed3136'
'ee66f3cd0c5bc0ba0f65499784d19f30'
'9d3c56a4b999c8bfbd4018089a62f662')
diff --git a/config.x86_64 b/config.x86_64
index 991c1a02152e..e54edf493b4b 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -881,7 +881,8 @@ CONFIG_HW_CONSOLE=y
CONFIG_VT_HW_CONSOLE_BINDING=y
CONFIG_UNIX98_PTYS=y
CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
-# CONFIG_LEGACY_PTYS is not set
+CONFIG_LEGACY_PTYS=y
+CONFIG_LEGACY_PTY_COUNT=256
# CONFIG_SERIAL_NONSTANDARD is not set
# CONFIG_N_GSM is not set
# CONFIG_TRACE_SINK is not set
diff --git a/nconfig-wrapper b/nconfig-wrapper
index c1f6856d7094..70b50f32ea63 100755
--- a/nconfig-wrapper
+++ b/nconfig-wrapper
@@ -1,8 +1,9 @@
#!/bin/bash
-[ -a ./package-this ] || {
+[ -a ./nconfig-wrapper ] || {
echo "You have to run this from the same directory!"
exit 1
}
+croak() { echo "ERROR: $@"; exit; }
[ -f /etc/bash.functions ] && . /etc/bash.functions
[ -f /usr/share/ppz/bash.functions ] && . /usr/share/ppz/bash.functions
[ "$1" ] && REPO="$1" || croak USAGE: ./package-this [repo-directory]
@@ -29,9 +30,13 @@ askyn "update package?" && {
sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
makepkg -oecd
makepkg -cd
- PF=$(ls -1tr *.pkg.tar.xz | tail -n 1)
- mv $PF ${REPO}
- repo-add ${REPO}/hir.db.tar.gz ${REPO}/$PF
+ PF=$(ls -1Atr linux-linode-*.pkg.tar.xz | tail -n 1)
+ mv "${PF}" "${REPO}"/
+ repo-add "${REPO}"/hir.db.tar.gz "${REPO}/${PF}"
+ IFS=$'\n'
+ for file in $(ls -1Atr "${REPO}"/linux-linode-*.pkg.tar.xz | head -n -1); do
+ rm -i "$file"
+ done
} || {
sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
makepkg -oecd