aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortwomyn2012-03-18 22:39:14 -0700
committeryar2015-07-03 16:58:14 -0700
commitb58a5cf11afa4f42bb5400aba9ca3317704cd878 (patch)
treef32fa1ad6d9a2a9dbf8d177ced1dc700dbf334d0
parentb5cf346d983147933434c0a7dfe908e4d1e9419c (diff)
downloadaur-b58a5cf11afa4f42bb5400aba9ca3317704cd878.tar.gz
Bump 3.2.11
Cosmetic changes to config, only. New file, guide to updating, hopefully will make this less intimidating. Did not incorporate the ext[234] config - wait until patch is upstream?
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--UPDATING39
-rw-r--r--config.x86_6426
-rw-r--r--linux-linode.install2
5 files changed, 62 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67d8ec3bca34..c1a04c8334ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux
pkgdesc = The Linux Kernel and modules
- pkgver = 3.2.5
- pkgrel = 2
+ pkgver = 3.2.11
+ pkgrel = 1
url = http://www.kernel.org/
install = linux-linode.install
arch = x86_64
@@ -21,14 +21,14 @@ pkgbase = linux
options = !strip
backup = etc/mkinitcpio.d/linux-linode.preset
source = http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.2.tar.xz
- source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.2.5.xz
+ source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.2.11.xz
source = config.x86_64
source = menu.lst
source = linux-linode.preset
source = change-default-console-loglevel.patch
md5sums = 364066fa18767ec0ae5f4e4abcf9dc51
- md5sums = 89cb9fb7ed01dccb15510435fb1e5024
- md5sums = 12eac810a451951eb7b48b2c76f5f489
+ md5sums = 39b3efb92f23130c3fd9c3cbdcd9ecb1
+ md5sums = d44738cf084b5d58e6fc8b8a78127ad3
md5sums = 7fc8bdda8379469552523e9296dc3799
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
diff --git a/PKGBUILD b/PKGBUILD
index 8bd9dbe0c7c9..a46baa1962ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@ pkgbase=linux
pkgname=linux-linode
_kernelname=${pkgname#linux}
_basekernel=3.2
-pkgver=${_basekernel}.5
-pkgrel=2
+pkgver=${_basekernel}.11
+pkgrel=1
arch=(x86_64)
url="http://www.kernel.org/"
license=(GPL2)
@@ -16,8 +16,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.2.tar.xz"
"${pkgname}.preset"
'change-default-console-loglevel.patch')
md5sums=('364066fa18767ec0ae5f4e4abcf9dc51'
- '89cb9fb7ed01dccb15510435fb1e5024'
- '12eac810a451951eb7b48b2c76f5f489'
+ '39b3efb92f23130c3fd9c3cbdcd9ecb1'
+ 'd44738cf084b5d58e6fc8b8a78127ad3'
'7fc8bdda8379469552523e9296dc3799'
'ee66f3cd0c5bc0ba0f65499784d19f30'
'9d3c56a4b999c8bfbd4018089a62f662')
diff --git a/UPDATING b/UPDATING
new file mode 100644
index 000000000000..0eae9e20788c
--- /dev/null
+++ b/UPDATING
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+# How to update this package!
+
+# Don't actually run this as a shell script - it's part pseudocode
+exit
+
+# Check https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
+# Bump pkgver, pkgrel
+# Sync any new PKGBUILD logic, important patches, configs or other changes
+
+# Cleans things up
+makepkg -oecd
+
+# uncomment "return 1"
+sed -i 's/^[#]*\s*\(return\s*1\)$/\1/ig' PKGBUILD
+
+# sources are ready
+makepkg -cd
+
+# will probably fail for hashes, reset hashes & redo
+
+# may prompt for oldconfig
+
+# do a checkup
+cd src/linux-${pkgver}
+make nconfig
+# save as .config, then quit
+
+# last check
+diff ../../config.x86_64 .config
+
+# move it back
+cd ../..
+cp src/linux-${pkgver}/.config config.x86_64
+
+# update md5s
+# re-comment "return 1"
+sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
diff --git a/config.x86_64 b/config.x86_64
index f8dc758125fe..71823880e616 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.2.5-1 Kernel Configuration
+# Linux/x86_64 3.2.11-1 Kernel Configuration
#
CONFIG_64BIT=y
# CONFIG_X86_32 is not set
@@ -825,32 +825,32 @@ CONFIG_DM_MULTIPATH=y
# CONFIG_DM_FLAKEY is not set
# CONFIG_MACINTOSH_DRIVERS is not set
CONFIG_NETDEVICES=y
-CONFIG_DUMMY=y
CONFIG_NET_CORE=y
CONFIG_BONDING=m
-# CONFIG_MACVLAN is not set
+CONFIG_DUMMY=y
# CONFIG_EQUALIZER is not set
+# CONFIG_MII is not set
+# CONFIG_MACVLAN is not set
+# CONFIG_NETCONSOLE is not set
+# CONFIG_NETPOLL is not set
+# CONFIG_NET_POLL_CONTROLLER is not set
CONFIG_TUN=m
# CONFIG_VETH is not set
-# CONFIG_MII is not set
+
+#
+# CAIF transport drivers
+#
# CONFIG_ETHERNET is not set
# CONFIG_PHYLIB is not set
+# CONFIG_PPP is not set
+# CONFIG_SLIP is not set
# CONFIG_WLAN is not set
#
# Enable WiMAX (Networking options) to see the WiMAX drivers
#
# CONFIG_WAN is not set
-
-#
-# CAIF transport drivers
-#
CONFIG_XEN_NETDEV_FRONTEND=y
-# CONFIG_PPP is not set
-# CONFIG_SLIP is not set
-# CONFIG_NETCONSOLE is not set
-# CONFIG_NETPOLL is not set
-# CONFIG_NET_POLL_CONTROLLER is not set
# CONFIG_ISDN is not set
# CONFIG_PHONE is not set
diff --git a/linux-linode.install b/linux-linode.install
index a3a22d772267..1ee9dbbd50f1 100644
--- a/linux-linode.install
+++ b/linux-linode.install
@@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-linode
-KERNEL_VERSION=3.2.5-2-linode
+KERNEL_VERSION=3.2.11-1-linode
post_install () {
echo ">>> Updating module dependencies. Please wait ..."