aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2012-12-20 10:32:46 -0800
committeryar2015-07-03 16:58:20 -0700
commitc0dea8056cd7a1836697c4e0f722a6f1b950e04a (patch)
tree3260f5b8ec64487fd3e30a0d11a2df72fd883763
parente1f89868f59a7c939e6a5fa7d20ebe786aaf2148 (diff)
downloadaur-c0dea8056cd7a1836697c4e0f722a6f1b950e04a.tar.gz
bump 3.7.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--config2
-rw-r--r--config.x86_642
-rw-r--r--linux-linode.install2
5 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6c39bc86a3..b6a84256fa59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-linode
pkgdesc = Kernel for Arch Linux on Linode
- pkgver = 3.7.0
- pkgrel = 2
+ pkgver = 3.7.1
+ pkgrel = 1
url = https://github.com/yardenac/linux-linode
install = linux-linode.install
arch = i686
@@ -25,14 +25,16 @@ pkgbase = linux-linode
backup = etc/mkinitcpio.d/linux-linode.preset
backup = boot/grub/menu.lst
source = http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.7.tar.xz
+ source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.7.1.xz
source = config
source = config.x86_64
source = menu.lst
source = linux-linode.preset
source = change-default-console-loglevel.patch
md5sums = 21223369d682bcf44bcdfe1521095983
- md5sums = c316bece16c3c09d808966c1bbd30d8c
- md5sums = f4e8917cc2223741e6fc13c61a6186a7
+ md5sums = 48f5f530b048e387e978e3e49de7742a
+ md5sums = e7cacdfb2aec83541c287ef419a9f43d
+ md5sums = 5ab6a4c7b056753c72f312c581d6b275
md5sums = d01f2350ec9f92e2eabcde0f11be24f2
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
diff --git a/PKGBUILD b/PKGBUILD
index d37cdc4e855d..d4ee0129270e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@ pkgname=linux-linode
_basekernel=3.7
_kernelname=${pkgname#linux}
_srcname=linux-${_basekernel}
-pkgver=${_basekernel}.0
-pkgrel=2
+pkgver=${_basekernel}.1
+pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/yardenac/linux-linode"
license=(GPL2)
makedepends=(xmlto docbook-xsl)
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
-# "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
'config'
'config.x86_64'
'menu.lst'
"${pkgname}.preset"
'change-default-console-loglevel.patch')
md5sums=('21223369d682bcf44bcdfe1521095983'
- 'c316bece16c3c09d808966c1bbd30d8c'
- 'f4e8917cc2223741e6fc13c61a6186a7'
+ '48f5f530b048e387e978e3e49de7742a'
+ 'e7cacdfb2aec83541c287ef419a9f43d'
+ '5ab6a4c7b056753c72f312c581d6b275'
'd01f2350ec9f92e2eabcde0f11be24f2'
'ee66f3cd0c5bc0ba0f65499784d19f30'
'9d3c56a4b999c8bfbd4018089a62f662')
@@ -32,7 +33,7 @@ install=${pkgname}.install
build() {
cd "${srcdir}/${_srcname}"
-# patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
diff --git a/config b/config
index f43c40e8edec..ec5ea79120df 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/i386 3.7.0-1 Kernel Configuration
+# Linux/i386 3.7.1-1 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
diff --git a/config.x86_64 b/config.x86_64
index 6fb925d03be2..1196365f02ce 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.7.0-1 Kernel Configuration
+# Linux/x86_64 3.7.1-1 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
diff --git a/linux-linode.install b/linux-linode.install
index 00e871e86f44..f786a942c0c6 100644
--- a/linux-linode.install
+++ b/linux-linode.install
@@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-linode
-KERNEL_VERSION=3.7.0-1-linode
+KERNEL_VERSION=3.7.1-1-linode
export PATH='/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'