aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-02-05 12:46:42 -0800
committeryar2015-07-03 16:58:21 -0700
commitdcf7d8f24a5dad98fd2390bcfa5a427036f77ffd (patch)
treeb28738365987cfa4556bdbc725ede3e0fac705ff
parentb1c643ce0f046acefe3f703bd77e4eeb03efd91f (diff)
downloadaur-dcf7d8f24a5dad98fd2390bcfa5a427036f77ffd.tar.gz
remove watchdog patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--fix-watchdog-3.7.patch38
3 files changed, 0 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d48b8c56fcfe..690e864db5c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -30,7 +30,6 @@ pkgbase = linux-linode
source = config.x86_64
source = menu.lst
source = linux-linode.preset
- source = fix-watchdog-3.7.patch
source = change-default-console-loglevel.patch
md5sums = 21223369d682bcf44bcdfe1521095983
md5sums = 132211742278e18b8f4808754d85e66c
@@ -38,7 +37,6 @@ pkgbase = linux-linode
md5sums = c8eaf98829288430609ab534c5c0b96a
md5sums = d01f2350ec9f92e2eabcde0f11be24f2
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
- md5sums = 05825098356199a0d76bd5b337bab2e4
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
pkgname = linux-linode
diff --git a/PKGBUILD b/PKGBUILD
index f574a4271863..269c5079f1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,6 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'config.x86_64'
'menu.lst'
"${pkgname}.preset"
- 'fix-watchdog-3.7.patch'
'change-default-console-loglevel.patch')
md5sums=('21223369d682bcf44bcdfe1521095983'
'132211742278e18b8f4808754d85e66c'
@@ -23,7 +22,6 @@ md5sums=('21223369d682bcf44bcdfe1521095983'
'c8eaf98829288430609ab534c5c0b96a'
'd01f2350ec9f92e2eabcde0f11be24f2'
'ee66f3cd0c5bc0ba0f65499784d19f30'
- '05825098356199a0d76bd5b337bab2e4'
'9d3c56a4b999c8bfbd4018089a62f662')
pkgdesc="Kernel for Arch Linux on Linode"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
@@ -36,7 +34,6 @@ install=${pkgname}.install
build() {
cd "${srcdir}/${_srcname}"
patch -p1 -i "${srcdir}/patch-${pkgver}"
- patch -Np1 -i "${srcdir}/fix-watchdog-3.7.patch"
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
diff --git a/fix-watchdog-3.7.patch b/fix-watchdog-3.7.patch
deleted file mode 100644
index 2a8e77a8a922..000000000000
--- a/fix-watchdog-3.7.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux.git;a=blobdiff_plain;f=kernel%2Fwatchdog.c;h=75a2ab3d0b0208dfa51e40339ffd00206622732e;hp=997c6a16ec2278969a10f251f63f237e7559d42e;hb=3935e89505a1c3ab3f3b0c7ef0eae54124f48905;hpb=74779e22261172ea728b989310f6ecc991b57d62
-
-diff --git a/kernel/watchdog.c b/kernel/watchdog.c
-index 997c6a1..75a2ab3 100644
---- a/kernel/watchdog.c
-+++ b/kernel/watchdog.c
-@@ -344,6 +344,10 @@ static void watchdog_enable(unsigned int cpu)
- {
- struct hrtimer *hrtimer = &__raw_get_cpu_var(watchdog_hrtimer);
-
-+ /* kick off the timer for the hardlockup detector */
-+ hrtimer_init(hrtimer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
-+ hrtimer->function = watchdog_timer_fn;
-+
- if (!watchdog_enabled) {
- kthread_park(current);
- return;
-@@ -352,10 +356,6 @@ static void watchdog_enable(unsigned int cpu)
- /* Enable the perf event */
- watchdog_nmi_enable(cpu);
-
-- /* kick off the timer for the hardlockup detector */
-- hrtimer_init(hrtimer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
-- hrtimer->function = watchdog_timer_fn;
--
- /* done here because hrtimer_start can only pin to smp_processor_id() */
- hrtimer_start(hrtimer, ns_to_ktime(sample_period),
- HRTIMER_MODE_REL_PINNED);
-@@ -369,9 +369,6 @@ static void watchdog_disable(unsigned int cpu)
- {
- struct hrtimer *hrtimer = &__raw_get_cpu_var(watchdog_hrtimer);
-
-- if (!watchdog_enabled)
-- return;
--
- watchdog_set_prio(SCHED_NORMAL, 0);
- hrtimer_cancel(hrtimer);
- /* disable the perf event */