summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-12-02 18:49:42 +0100
committerPiotr Gorski2018-12-02 18:49:42 +0100
commit12fb0b743777bbf46efca73a9d79e2c0201a14cd (patch)
tree2cf8db05a4841d28c420aeb2f221c414322a2ea3
parent44cfcaeb9b23a99df7e9a347f769a81861d7dc08 (diff)
downloadaur-12fb0b743777bbf46efca73a9d79e2c0201a14cd.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c20826f9c2cb..6c8b6361c619 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-lqx
pkgver = 4.18.20_3
- pkgrel = 2
+ pkgrel = 3
url = http://liquorix.net/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 17ff94d2bfdc..0cd7eb6ffa39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,9 +31,7 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -65,7 +63,7 @@ _lqxpatchrel=28
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=4.18.20_3
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
@@ -175,11 +173,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ msg2 "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
make localmodconfig
fi
fi