summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-08-22 13:18:03 +0200
committerPiotr Gorski2018-08-22 13:18:03 +0200
commit5c3a7fec1607ab86472d03ef1b32ec6e43f675c3 (patch)
tree4eead003a437a795fd5f3b61bd9f97889df64dff
parent5ce6de498c641019df18fd679c2c95129c81fe54 (diff)
downloadaur-5c3a7fec1607ab86472d03ef1b32ec6e43f675c3.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5338ec3e2a4..95cc43849634 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = linux-lqx
makedepends = inetutils
makedepends = bc
makedepends = libelf
+ makedepends = python-sphinx
+ makedepends = graphviz
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.tar.sign
diff --git a/PKGBUILD b/PKGBUILD
index 827ab5fe99c3..666882d374f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
options=('!strip')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf')
+makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'python-sphinx' 'graphviz')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
@@ -188,7 +188,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -343,10 +343,22 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}