summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-28 00:21:30 +0100
committerPiotr Gorski2018-11-28 00:21:30 +0100
commit5d99fc68d78504ae696b8359a38b9739c8e2266b (patch)
tree87dd45c9351ea395ebdd3a0ca6981f1ab88fd7d7
parent2d6c0bf444c20d13bab10702571a97aa63a23d95 (diff)
downloadaur-5d99fc68d78504ae696b8359a38b9739c8e2266b.tar.gz
Make lib/modules/*/vmlinuz a copy instead of a link
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--90-linux.hook2
-rw-r--r--99-linux.hook2
-rw-r--r--PKGBUILD19
-rw-r--r--linux.install1
5 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cc23ec53605..f355265b5ee9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-lqx
pkgver = 4.18.20_2
- pkgrel = 3
+ pkgrel = 4
url = http://liquorix.net/
arch = x86_64
license = GPL2
@@ -22,8 +22,8 @@ pkgbase = linux-lqx
sha512sums = SKIP
sha512sums = 8d3e2bd1b4e1328e543baad2013d1c07cec8d523a0fd8070c07ac4bacbdd3c65ae0a630107c50e35eb9bdc5a28c4b2cd0b15f69f44858d17deb6fe0263e646e8
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
- sha512sums = 4a8b324aee4cccf3a512ad04ce1a272d14e5b05c8de90feb82075f55ea3845948d817e1b0c6f298f5816834ddd3e5ce0a0e2619866289f3c1ab8fd2f35f04f44
- sha512sums = 6346b66f54652256571ef65da8e46db49a95ac5978ecd57a507c6b2a28aee70bb3ff87045ac493f54257c9965da1046a28b72cb5abb0087204d257f14b91fd74
+ sha512sums = 2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7
+ sha512sums = b27d13a1e486de6a8500724d2aea3fc11b2f46698e6aa5e41b37b8c8bbf973763b3c5eca464522ea198305167bace2a20ce4d1c40b01ce6f82838c81f3135f48
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
pkgname = linux-lqx
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/99-linux.hook b/99-linux.hook
index 036f6bf2534a..138b911b6794 100644
--- a/99-linux.hook
+++ b/99-linux.hook
@@ -1,7 +1,7 @@
[Trigger]
Type = File
Operation = Remove
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
[Action]
Description = Remove %PKGBASE% initramfs files...
diff --git a/PKGBUILD b/PKGBUILD
index ef4bbdfa3a81..4f3fe34466b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ _lqxpatchrel=27
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=4.18.20_2
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
@@ -218,22 +218,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
@@ -401,8 +398,8 @@ sha512sums=('950eb85ac743b291afe9f21cd174d823e25f11883ee62cecfbfff8fe8c5672aae70
'SKIP'
'8d3e2bd1b4e1328e543baad2013d1c07cec8d523a0fd8070c07ac4bacbdd3c65ae0a630107c50e35eb9bdc5a28c4b2cd0b15f69f44858d17deb6fe0263e646e8'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
- '4a8b324aee4cccf3a512ad04ce1a272d14e5b05c8de90feb82075f55ea3845948d817e1b0c6f298f5816834ddd3e5ce0a0e2619866289f3c1ab8fd2f35f04f44'
- '6346b66f54652256571ef65da8e46db49a95ac5978ecd57a507c6b2a28aee70bb3ff87045ac493f54257c9965da1046a28b72cb5abb0087204d257f14b91fd74'
+ '2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
+ 'b27d13a1e486de6a8500724d2aea3fc11b2f46698e6aa5e41b37b8c8bbf973763b3c5eca464522ea198305167bace2a20ce4d1c40b01ce6f82838c81f3135f48'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf')
validpgpkeys=(
diff --git a/linux.install b/linux.install
index 95860e414f7e..f7bdeb92e69e 100644
--- a/linux.install
+++ b/linux.install
@@ -4,3 +4,4 @@ post_upgrade() {
fi
}
+# vim:set ft=sh ts=8 sts=2 sw=2 et: