summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barrett2024-01-07 12:58:57 -0600
committerSteven Barrett2024-01-07 12:58:57 -0600
commit975ff9eee08f3b51b9a852f9a9e5e2959d485c96 (patch)
tree720171f6b9a9c39e4a0bdf69f10311f481129b94
parentec9817a47da803b7a277a35c5c7bd4d61d412280 (diff)
downloadaur-975ff9eee08f3b51b9a852f9a9e5e2959d485c96.tar.gz
Revert "Remove debug workarounds, we no longer build with CONFIG_DEBUG_INFO"
Needed after re-enabling debug configuration. This reverts commit c622099099d1b33802af6cd052ade11d8b527df0.
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4e12bd821fb..0726a432ef6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -210,6 +210,10 @@ prepare() {
fi
fi
+ ## Use DWARF5 debug info for Arch
+ echo "Upgrading debug info from toolchain default to DWARF v5..."
+ scripts/config -e CONFIG_DEBUG_INFO_DWARF5
+
### Running make nconfig
[[ -z "$_makenconfig" ]] || make nconfig
@@ -281,6 +285,10 @@ _package-headers() {
# required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids \
+ || true
+
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include