summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barrett2024-02-01 16:46:24 -0600
committerSteven Barrett2024-02-01 16:46:24 -0600
commitffbfe137ebe76af941dce82098273eec4f4d6faa (patch)
treef85fef0820283f1978360be44c6647699a3d10e5
parentee36e09f0338c0532be86b13bc790bd714f8384c (diff)
downloadaur-ffbfe137ebe76af941dce82098273eec4f4d6faa.tar.gz
Process all zen patches in series file
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f793a02e581..a2df9e985e39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -117,11 +117,12 @@ prepare() {
_patchrel="$(echo "$_abiname" | cut -f2 -d -)"
### Add Liquorix patches
- local _patchrx='^zen/v\d+\.\d+\.\d+-lqx\d+.patch$'
local _patchfolder="${srcdir}/${_lqxpatchver}/linux-liquorix/debian/patches"
- local _patchpath="$(grep -P "$_patchrx" "$_patchfolder/series")"
- echo "Patching sources with ${_patchpath#*/}"
- patch -Np1 -i "$_patchfolder/$_patchpath"
+ grep -P '^zen/' "$_patchfolder/series" | while IFS= read -r line
+ do
+ echo "Patching sources with $line"
+ patch -Np1 -i "$_patchfolder/$line"
+ done
### Setting version
echo "Setting version..."