summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2021-02-25 12:15:35 +1100
committerchrisjbillington2021-02-25 12:15:52 +1100
commit801c5db5e7ee01f7f3a765ebe8e7c23d257ed1d5 (patch)
treeff92ba76b23b16e10b22db7fe6cb7c7aadd76f30
parent10c4200b11caa0990fc104c33889d3fb04c531b0 (diff)
downloadaur-801c5db5e7ee01f7f3a765ebe8e7c23d257ed1d5.tar.gz
update script: updpkgsums before checking diff
-rw-r--r--update.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/update.py b/update.py
index 574c65810450..ee2494b4739c 100644
--- a/update.py
+++ b/update.py
@@ -55,9 +55,10 @@ pkgbuild = template.substitute(
pkgbuild = '\n'.join(line for line in pkgbuild.splitlines() if not line.endswith('=()'))
Path('PKGBUILD').write_text(pkgbuild + '\n')
+subprocess.check_call(['updpkgsums'])
+
if subprocess.check_output(['git', 'diff', 'PKGBUILD']).strip():
print("linux-lts-versioned-bin is out of date!")
- subprocess.check_call(['updpkgsums'])
with open('.SRCINFO', 'w') as f:
f.write(subprocess.check_output(['makepkg', '--printsrcinfo']).decode())