summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-01-12 08:30:26 -0500
committerTony Lambiris2019-01-12 08:30:26 -0500
commit399ef0d5ce551c2a3a3a7654b8cce059bb63f51e (patch)
treee4000139a6df7be15d8455894eb18da408e9717b
parent4ae0c79fdd2ace6d34854a88c8a1cbc703ac438e (diff)
downloadaur-399ef0d5ce551c2a3a3a7654b8cce059bb63f51e.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--config4
-rw-r--r--linux.install34
4 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401530d6c978..edd6999d3c8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-macbook
- pkgver = 4.20.arch1
+ pkgver = 4.20.1.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.20-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.20.1-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -13,7 +13,7 @@ pkgbase = linux-macbook
makedepends = python-sphinx
makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.20-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.20.1-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -24,7 +24,7 @@ pkgbase = linux-macbook
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = 3f72b50a40e98737a6195b6d2b3c8c301007d40730bc4ec37fdf9e57dceb6fb9
+ sha256sums = 72be7e1240975218dd370a9ce7e10f0b77e7fd9585ae8cdec0deab1800b307fe
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
diff --git a/PKGBUILD b/PKGBUILD
index d05270d7de5d..0f2fe47e305a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
-_srcver=4.20-arch1
+_srcver=4.20.1-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -29,7 +29,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '3f72b50a40e98737a6195b6d2b3c8c301007d40730bc4ec37fdf9e57dceb6fb9'
+ '72be7e1240975218dd370a9ce7e10f0b77e7fd9585ae8cdec0deab1800b307fe'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/config b/config
index 69e783205a2a..51aacf8719fe 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.20.0-arch1 Kernel Configuration
+# Linux/x86 4.20.1-arch1 Kernel Configuration
#
#
@@ -7240,10 +7240,10 @@ CONFIG_TYPEC_MUX_PI3USB30532=m
# USB Type-C Alternate Mode drivers
#
CONFIG_TYPEC_DP_ALTMODE=m
+CONFIG_USB_ROLE_SWITCH=m
CONFIG_USB_ROLES_INTEL_XHCI=m
CONFIG_USB_LED_TRIG=y
CONFIG_USB_ULPI_BUS=m
-CONFIG_USB_ROLE_SWITCH=m
CONFIG_UWB=m
CONFIG_UWB_HWA=m
CONFIG_UWB_WHCI=m
diff --git a/linux.install b/linux.install
index 7127469f1fb9..6c0c8e2d50d6 100644
--- a/linux.install
+++ b/linux.install
@@ -1,27 +1,29 @@
-display_requirements () {
-cat <<-EOF
+display_display_message () {
+ cat <<-EOF
- To get suspend working properly you must do the following:
+ To get suspend working properly you must do the following:
- Enable the macbook-wakeup service for suspend/resume on LID events:
- systemctl enable --now macbook-wakeup.service
+ Enable the macbook-wakeup service for suspend/resume on LID events:
+ systemctl enable --now macbook-wakeup.service
- Optionally, include the kernel boot option processor.ignore_ppc=1
- to allow frequency changing on battery power.
+ Optionally, include the kernel boot option processor.ignore_ppc=1
+ to allow frequency changing on battery power.
-EOF
+ EOF
+}
+
+post_install() {
+ display_message
}
post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
- display_requirements
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+ display_message
}
post_remove() {
- rm -f boot/initramfs-%PKGBASE%.img
- rm -f boot/initramfs-%PKGBASE%-fallback.img
+ rm -f boot/initramfs-%PKGBASE%.img
+ rm -f boot/initramfs-%PKGBASE%-fallback.img
}
-
-# vim:set ft=sh ts=8 sts=2 sw=2 et: