summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-03-29 00:00:11 -0400
committerTony Lambiris2018-03-29 00:00:11 -0400
commit4550e25afbaf41eebfc4418d445a9668beb98f95 (patch)
treeaa61fc417b81f41aff9f1159b7461baf23e04575
parent2b509d407ab5815fedf6747594f06f57959c6676 (diff)
downloadaur-4550e25afbaf41eebfc4418d445a9668beb98f95.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch80
-rw-r--r--PKGBUILD4
3 files changed, 6 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac24497f9230..4f6440ac661d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-macbook
- pkgver = 4.15.12
+ pkgver = 4.15.14
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = linux-macbook
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.12.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.12.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.14.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.15.14.sign
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -27,7 +27,7 @@ pkgbase = linux-macbook
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769
sha256sums = SKIP
- sha256sums = 74d2ac2ea103c907213223fd4ff710ad53e1d8a2d612db18e10d3dda9f1a6b79
+ sha256sums = 6be2c185839d730769a8e6bcf46ca0962845732e25ed4801fe1ea995218b1133
sha256sums = SKIP
sha256sums = f38927db126ec7141ea2dd70cabb2ef378552672b31db4ab621493928497abd7
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
diff --git a/0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch b/0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
deleted file mode 100644
index 4b490730e3c3..000000000000
--- a/0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From cd0c80aa02dbfe649c743fa98fcc0d9f427e0827 Mon Sep 17 00:00:00 2001
-Message-Id: <cd0c80aa02dbfe649c743fa98fcc0d9f427e0827.1518828081.git.jan.steffens@gmail.com>
-In-Reply-To: <05a43fb8b36cdaf6a3580f46cab334f2c2796544.1518828081.git.jan.steffens@gmail.com>
-References: <05a43fb8b36cdaf6a3580f46cab334f2c2796544.1518828081.git.jan.steffens@gmail.com>
-From: Juergen Gross <jgross@suse.com>
-Date: Thu, 1 Feb 2018 13:40:19 +0100
-Subject: [PATCH 3/3] x86/xen: init %gs very early to avoid page faults with
- stack protector
-
-When running as Xen pv guest %gs is initialized some time after
-C code is started. Depending on stack protector usage this might be
-too late, resulting in page faults.
-
-So setup %gs and MSR_GS_BASE in assembly code already.
-
-Cc: stable@vger.kernel.org
-Signed-off-by: Juergen Gross <jgross@suse.com>
-Reviewed-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
-Tested-by: Chris Patterson <cjp256@gmail.com>
-Signed-off-by: Juergen Gross <jgross@suse.com>
----
- arch/x86/xen/xen-head.S | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/arch/x86/xen/xen-head.S b/arch/x86/xen/xen-head.S
-index 497cc55a0c16..96f26e026783 100644
---- a/arch/x86/xen/xen-head.S
-+++ b/arch/x86/xen/xen-head.S
-@@ -9,32 +9,48 @@
-
- #include <asm/boot.h>
- #include <asm/asm.h>
-+#include <asm/msr.h>
- #include <asm/page_types.h>
-+#include <asm/percpu.h>
- #include <asm/unwind_hints.h>
-
- #include <xen/interface/elfnote.h>
- #include <xen/interface/features.h>
- #include <xen/interface/xen.h>
- #include <xen/interface/xen-mca.h>
- #include <asm/xen/interface.h>
-
- #ifdef CONFIG_XEN_PV
- __INIT
- ENTRY(startup_xen)
- UNWIND_HINT_EMPTY
- cld
-
- /* Clear .bss */
- xor %eax,%eax
- mov $__bss_start, %_ASM_DI
- mov $__bss_stop, %_ASM_CX
- sub %_ASM_DI, %_ASM_CX
- shr $__ASM_SEL(2, 3), %_ASM_CX
- rep __ASM_SIZE(stos)
-
- mov %_ASM_SI, xen_start_info
- mov $init_thread_union+THREAD_SIZE, %_ASM_SP
-
-+#ifdef CONFIG_X86_64
-+ /* Set up %gs.
-+ *
-+ * The base of %gs always points to the bottom of the irqstack
-+ * union. If the stack protector canary is enabled, it is
-+ * located at %gs:40. Note that, on SMP, the boot cpu uses
-+ * init data section till per cpu areas are set up.
-+ */
-+ movl $MSR_GS_BASE,%ecx
-+ movq $INIT_PER_CPU_VAR(irq_stack_union),%rax
-+ cdq
-+ wrmsr
-+#endif
-+
- jmp xen_start_kernel
- END(startup_xen)
- __FINIT
---
-2.16.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 03ca680046bb..06a17d932797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
_srcname=linux-4.15
-pkgver=4.15.12
+pkgver=4.15.14
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -32,7 +32,7 @@ validpgpkeys=(
)
sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'SKIP'
- '74d2ac2ea103c907213223fd4ff710ad53e1d8a2d612db18e10d3dda9f1a6b79'
+ '6be2c185839d730769a8e6bcf46ca0962845732e25ed4801fe1ea995218b1133'
'SKIP'
'f38927db126ec7141ea2dd70cabb2ef378552672b31db4ab621493928497abd7'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'