summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-11-27 13:19:45 -0500
committerTony Lambiris2017-11-27 13:19:45 -0500
commitc85a70c324db1a2e584ab4baec97f1571af00aec (patch)
tree0458ad8cbc9eb73879d1a894dce929f9df3c97b9
parent49e217a546d3236984fdb0d66d0c272519ce8415 (diff)
downloadaur-c85a70c324db1a2e584ab4baec97f1571af00aec.tar.gz
Version bump
-rw-r--r--.SRCINFO12
-rw-r--r--0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch39
-rw-r--r--PKGBUILD13
3 files changed, 9 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a71f67617ea..4e0dffee18e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-macbook
- pkgver = 4.14.1
- pkgrel = 2
+ pkgver = 4.14.2
+ pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -12,8 +12,8 @@ pkgbase = linux-macbook
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.14.1.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.14.1.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.14.2.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.14.2.sign
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -25,12 +25,11 @@ pkgbase = linux-macbook
source = RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
source = intel-pstate-backport.patch
source = 0001-platform-x86-hp-wmi-Fix-tablet-mode-detection-for-co.patch
- source = 0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7
sha256sums = SKIP
- sha256sums = 5af72b487fbcc8e7fd3f5392271490c8498ffb2048e77abaf406971a7382f8d7
+ sha256sums = 2dc86272e55d31c55bdeaa47b3d44fbd6235a396e37d82c2b47aa27f6ba82ee3
sha256sums = SKIP
sha256sums = a68e94064f040d60e8e4c3380efeee085b54d252d527e960dd17ac688505d5b6
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
@@ -43,7 +42,6 @@ pkgbase = linux-macbook
sha256sums = 09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff
sha256sums = 3d9fdbb4bee270efa6eef1d8e40a5ae562a87d5a2edae629e0829cc51714de13
sha256sums = 6f1d9b6a119bfab150a0bc1f550609dd9290328df709b67c984f0a6b0abe8afd
- sha256sums = 92b8755030d405fa4a9cd31cbe2998fd71584164431e5edc28c2be04fab24d1e
pkgname = linux-macbook
pkgdesc = The Linux-macbook kernel and modules
diff --git a/0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch b/0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch
deleted file mode 100644
index c9f4a3a3a347..000000000000
--- a/0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 62530ed8b1d07a45dec94d46e521c0c6c2d476e6 Mon Sep 17 00:00:00 2001
-Message-Id: <62530ed8b1d07a45dec94d46e521c0c6c2d476e6.1511339979.git.jan.steffens@gmail.com>
-From: Michael Lyle <mlyle@lyle.org>
-Date: Thu, 16 Nov 2017 23:47:25 -0800
-Subject: [PATCH] bio: ensure __bio_clone_fast copies bi_partno
-
-A new field was introduced in 74d46992e0d9, bi_partno, instead of using
-bdev->bd_contains and encoding the partition information in the bi_bdev
-field. __bio_clone_fast was changed to copy the disk information, but
-not the partition information. At minimum, this regressed bcache and
-caused data corruption.
-
-Signed-off-by: Michael Lyle <mlyle@lyle.org>
-Fixes: 74d46992e0d9 ("block: replace bi_bdev with a gendisk pointer and partitions index")
-Reported-by: Pavel Goran <via-bcache@pvgoran.name>
-Reported-by: Campbell Steven <casteven@gmail.com>
-Reviewed-by: Coly Li <colyli@suse.de>
-Reviewed-by: Ming Lei <ming.lei@redhat.com>
-Cc: <stable@vger.kernel.org> # 4.14
-Signed-off-by: Jens Axboe <axboe@kernel.dk>
----
- block/bio.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/block/bio.c b/block/bio.c
-index b94a802f8ba34189..459cc857f3d91647 100644
---- a/block/bio.c
-+++ b/block/bio.c
-@@ -597,6 +597,7 @@ void __bio_clone_fast(struct bio *bio, struct bio *bio_src)
- * so we don't set nor calculate new physical/hw segment counts here
- */
- bio->bi_disk = bio_src->bi_disk;
-+ bio->bi_partno = bio_src->bi_partno;
- bio_set_flag(bio, BIO_CLONED);
- bio->bi_opf = bio_src->bi_opf;
- bio->bi_write_hint = bio_src->bi_write_hint;
---
-2.15.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 982d5c928bf2..858b23f30d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
_srcname=linux-4.14
-pkgver=4.14.1
-pkgrel=2
+pkgver=4.14.2
+pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -30,7 +30,6 @@ source=(
'RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch'
'intel-pstate-backport.patch'
'0001-platform-x86-hp-wmi-Fix-tablet-mode-detection-for-co.patch'
- '0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch'
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -38,7 +37,7 @@ validpgpkeys=(
)
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'SKIP'
- '5af72b487fbcc8e7fd3f5392271490c8498ffb2048e77abaf406971a7382f8d7'
+ '2dc86272e55d31c55bdeaa47b3d44fbd6235a396e37d82c2b47aa27f6ba82ee3'
'SKIP'
'a68e94064f040d60e8e4c3380efeee085b54d252d527e960dd17ac688505d5b6'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
@@ -50,8 +49,7 @@ sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
'09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff'
'3d9fdbb4bee270efa6eef1d8e40a5ae562a87d5a2edae629e0829cc51714de13'
- '6f1d9b6a119bfab150a0bc1f550609dd9290328df709b67c984f0a6b0abe8afd'
- '92b8755030d405fa4a9cd31cbe2998fd71584164431e5edc28c2be04fab24d1e')
+ '6f1d9b6a119bfab150a0bc1f550609dd9290328df709b67c984f0a6b0abe8afd')
_kernelname=${pkgbase#linux}
@@ -88,9 +86,6 @@ prepare() {
# https://bugs.archlinux.org/task/56207
patch -Np1 -i ../0001-platform-x86-hp-wmi-Fix-tablet-mode-detection-for-co.patch
- # https://bugs.archlinux.org/task/56404
- patch -Np1 -i ../0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch
-
cp -Tf ../config .config
if [ "${_kernelname}" != "" ]; then