summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2023-03-07 22:52:09 +0100
committerMikael Eriksson2023-03-07 22:52:09 +0100
commit514956cb9a3b27363bc1b924e2b7f00396e7b9a2 (patch)
tree5d46ca10330dbef4d9b0b1d41f8e39a76de2ee9a
parent309d7755cd387ec913c663a6c5eaef746a75559c (diff)
downloadaur-514956cb9a3b27363bc1b924e2b7f00396e7b9a2.tar.gz
6.3rc1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--config2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7cd96c89ab6..c27e044daf82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-mainline
pkgdesc = Linux Mainline
- pkgver = 6.2
+ pkgver = 6.3rc1
pkgrel = 1
url = https://kernel.org/
arch = x86_64
@@ -21,13 +21,13 @@ pkgbase = linux-mainline
makedepends = texlive-latexextra
makedepends = git
options = !strip
- source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.2
+ source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.3-rc1
source = config
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
- sha256sums = 9fd08d03cf2de3325ca2c52282560a0b6ea63ee7801dc71d199e40c7a616d655
+ sha256sums = 3449f9cec5cb48f6804ef33a5575627ba769e57bdc43aba13a748d69cef5e73d
pkgname = linux-mainline
pkgdesc = The Linux Mainline kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index f0c56d71bea2..9ee2877bff37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
pkgbase=linux-mainline # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
-_tag=v6.2
-pkgver=6.2
+_tag=v6.3-rc1
+pkgver=6.3rc1
pkgrel=1
pkgdesc="Linux Mainline"
arch=(x86_64)
@@ -32,7 +32,7 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '9fd08d03cf2de3325ca2c52282560a0b6ea63ee7801dc71d199e40c7a616d655')
+ '3449f9cec5cb48f6804ef33a5575627ba769e57bdc43aba13a748d69cef5e73d')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -41,10 +41,10 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
- echo "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
+ #echo "Setting version..."
+ #scripts/setlocalversion
+ #echo "-$pkgrel" > localversion.10-pkgrel
+ #echo "${pkgbase#linux}" > localversion.20-pkgname
local src
for src in "${source[@]}"; do
@@ -106,7 +106,7 @@ _package-headers() {
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
diff --git a/config b/config
index cf7fddd2c1d9..6fc7458cb73d 100644
--- a/config
+++ b/config
@@ -479,7 +479,7 @@ CONFIG_X86_PAT=y
CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_X86_UMIP=y
CONFIG_CC_HAS_IBT=y
-CONFIG_X86_KERNEL_IBT=y
+CONFIG_X86_KERNEL_IBT=n
CONFIG_X86_INTEL_MEMORY_PROTECTION_KEYS=y
# CONFIG_X86_INTEL_TSX_MODE_OFF is not set
# CONFIG_X86_INTEL_TSX_MODE_ON is not set