summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2016-05-30 11:31:58 +0200
committerMikael Eriksson2016-05-30 13:16:10 +0200
commitb24ab5eba3ebb67031fb2ac565f99144011a8620 (patch)
treed0c0b8bec93eb151cc47fedcf355a9118d0606d3
parent22d5c389f079ff372c5ec9796a70e3f49771bc05 (diff)
downloadaur-b24ab5eba3ebb67031fb2ac565f99144011a8620.tar.gz
Merge with core 4.6-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
-rw-r--r--config2
-rw-r--r--config.x86_642
4 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e84fd7e5ad60..d2945fe36408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon May 16 10:41:24 UTC 2016
+# Mon May 30 11:16:03 UTC 2016
pkgbase = linux-mainline
pkgver = 4.6
pkgrel = 1
@@ -12,6 +12,7 @@ pkgbase = linux-mainline
makedepends = kmod
makedepends = inetutils
makedepends = bc
+ makedepends = elfutils
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.6.tar.xz
source = config
diff --git a/PKGBUILD b/PKGBUILD
index 9ddd6ec09c5e..f47947bd6605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
+makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'elfutils')
options=('!strip')
source=("https://cdn.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
#"https://cdn.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
@@ -251,6 +251,12 @@ _package-headers() {
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
done
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ if [ -f tools/objtool/objtool ]; then
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool"
+ cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
+ fi
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
diff --git a/config b/config
index 75d007bd048d..c3ff4cc54e8e 100644
--- a/config
+++ b/config
@@ -3859,7 +3859,7 @@ CONFIG_GPIO_SYSFS=y
# CONFIG_GPIO_GENERIC_PLATFORM is not set
# CONFIG_GPIO_GRGPIO is not set
CONFIG_GPIO_ICH=m
-CONFIG_GPIO_LYNXPOINT=m
+CONFIG_GPIO_LYNXPOINT=y
# CONFIG_GPIO_SYSCON is not set
# CONFIG_GPIO_VX855 is not set
# CONFIG_GPIO_XILINX is not set
diff --git a/config.x86_64 b/config.x86_64
index adbbd52b25fa..769b82c03922 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -3757,7 +3757,7 @@ CONFIG_GPIO_SYSFS=y
# CONFIG_GPIO_DWAPB is not set
# CONFIG_GPIO_GENERIC_PLATFORM is not set
CONFIG_GPIO_ICH=m
-CONFIG_GPIO_LYNXPOINT=m
+CONFIG_GPIO_LYNXPOINT=y
# CONFIG_GPIO_VX855 is not set
# CONFIG_GPIO_ZX is not set