summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2015-12-07 11:50:12 +0100
committerMikael Eriksson2015-12-07 11:50:12 +0100
commitcce6525445651f35230df6091786852e956e6e4f (patch)
tree3b6115e0322f7c14f381a8476805de2a5595b5af
parent6ff5dae13fc273670c20be00d0234363a56cc2a2 (diff)
downloadaur-cce6525445651f35230df6091786852e956e6e4f.tar.gz
4.4rc4-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--libcfs-fix.patch39
3 files changed, 6 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7497e8cdd44..4ebd13a0908d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-mainline
- pkgver = 4.4rc3
+ pkgver = 4.4rc4
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -12,15 +12,13 @@ pkgbase = linux-mainline
makedepends = bc
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.3.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-4.4-rc3.xz
- source = libcfs-fix.patch
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-4.4-rc4.xz
source = config
source = config.x86_64
source = linux.preset
source = change-default-console-loglevel.patch
sha256sums = 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae
- sha256sums = 41b73ce54efdde419218de2ca2b1bcc2bc135b5e33ab870e28eb328fca962855
- sha256sums = fd07e2d6ec71d2d87a977c4298f634fa1abfc75ddbd0d5b3ecf9befa7a4b82b4
+ sha256sums = e2a1f4198c0f56b0fb9cdf7056a3efb5c99d117e6c55341b69f8e77c01bea450
sha256sums = 596958c9c4b632fdf5e0cdc677859dccac4304ad07a217c9bcb0e4fa58dbea16
sha256sums = 333c14024cc8948f0f205f4eceac30060494d1ef0a785127500f5f568d36d38a
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
diff --git a/PKGBUILD b/PKGBUILD
index 67b8880446b8..b95c6e4b892b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
pkgbase=linux-mainline # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-4.3
-_patchname=patch-4.4-rc3
-pkgver=4.4rc3
+_patchname=patch-4.4-rc4
+pkgver=4.4rc4
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -18,7 +18,6 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
- "libcfs-fix.patch"
#"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.sign"
# the main kernel config files
@@ -27,8 +26,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'change-default-console-loglevel.patch')
sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
- '41b73ce54efdde419218de2ca2b1bcc2bc135b5e33ab870e28eb328fca962855'
- 'fd07e2d6ec71d2d87a977c4298f634fa1abfc75ddbd0d5b3ecf9befa7a4b82b4'
+ 'e2a1f4198c0f56b0fb9cdf7056a3efb5c99d117e6c55341b69f8e77c01bea450'
'596958c9c4b632fdf5e0cdc677859dccac4304ad07a217c9bcb0e4fa58dbea16'
'333c14024cc8948f0f205f4eceac30060494d1ef0a785127500f5f568d36d38a'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
@@ -50,9 +48,6 @@ prepare() {
# mainline: add patch
patch -p1 -i "${srcdir}/${_patchname}" || true
- # mainline: libcfs fix
- patch -p1 -i "${srcdir}/libcfs-fix.patch"
-
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
diff --git a/libcfs-fix.patch b/libcfs-fix.patch
deleted file mode 100644
index 671534b2a5f9..000000000000
--- a/libcfs-fix.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/drivers/staging/lustre/include/linux/libcfs/libcfs_ioctl.h b/drivers/staging/lustre/include/linux/libcfs/libcfs_ioctl.h
-index f5d741f..485ab26 100644
---- a/drivers/staging/lustre/include/linux/libcfs/libcfs_ioctl.h
-+++ b/drivers/staging/lustre/include/linux/libcfs/libcfs_ioctl.h
-@@ -110,7 +110,6 @@ struct libcfs_ioctl_handler {
- #define IOC_LIBCFS_CLEAR_DEBUG _IOWR('e', 31, long)
- #define IOC_LIBCFS_MARK_DEBUG _IOWR('e', 32, long)
- #define IOC_LIBCFS_MEMHOG _IOWR('e', 36, long)
--#define IOC_LIBCFS_PING_TEST _IOWR('e', 37, long)
- /* lnet ioctls */
- #define IOC_LIBCFS_GET_NI _IOWR('e', 50, long)
- #define IOC_LIBCFS_FAIL_NID _IOWR('e', 51, long)
-diff --git a/drivers/staging/lustre/lustre/libcfs/module.c b/drivers/staging/lustre/lustre/libcfs/module.c
-index 50e8fd2..5e22820 100644
---- a/drivers/staging/lustre/lustre/libcfs/module.c
-+++ b/drivers/staging/lustre/lustre/libcfs/module.c
-@@ -274,23 +274,6 @@ static int libcfs_ioctl_int(struct cfs_psdev_file *pfile, unsigned long cmd,
- }
- break;
-
-- case IOC_LIBCFS_PING_TEST: {
-- extern void (kping_client)(struct libcfs_ioctl_data *);
-- void (*ping)(struct libcfs_ioctl_data *);
--
-- CDEBUG(D_IOCTL, "doing %d pings to nid %s (%s)\n",
-- data->ioc_count, libcfs_nid2str(data->ioc_nid),
-- libcfs_nid2str(data->ioc_nid));
-- ping = symbol_get(kping_client);
-- if (!ping)
-- CERROR("symbol_get failed\n");
-- else {
-- ping(data);
-- symbol_put(kping_client);
-- }
-- return 0;
-- }
--
- default: {
- struct libcfs_ioctl_handler *hand;