summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2015-06-22 16:28:09 +0200
committerMikael Eriksson2015-06-22 16:28:09 +0200
commiteedd9e5c4b512f89142305be0a1602a33b6b184a (patch)
tree9aa67d88e84886702844d67902eaf7edf022dd7f
parentf7ee08f3e310d5f91515ca59c27e5807b46fb0be (diff)
downloadaur-eedd9e5c4b512f89142305be0a1602a33b6b184a.tar.gz
4.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ca219f9acb4..f57b28dd14b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-mainline
- pkgver = 4.1rc8
+ pkgver = 4.1
pkgrel = 1
url = https://imasheep.hurrdurr.org/
arch = i686
@@ -11,14 +11,12 @@ pkgbase = linux-mainline
makedepends = inetutils
makedepends = bc
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.0.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-4.1-rc8.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.xz
source = config
source = config.x86_64
source = linux.preset
source = change-default-console-loglevel.patch
- sha256sums = 0f2f7d44979bc8f71c4fc5d3308c03499c26a824dd311fdf6eef4dee0d7d5991
- sha256sums = dad6572b2e806bf0efbd6920c2a37aa3ba0349225eab85f7dcbc2de34399ec99
+ sha256sums = caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f
sha256sums = 514aa8a9d03d2419c8084725fcdb2b5b4ce07966f5bd6a51224a5f7a5f8c3694
sha256sums = b268b03a042e3f604a12a80c6e24c42006e4d9bf4a6d9b3201eb006942718128
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
@@ -32,20 +30,20 @@ pkgname = linux-mainline
depends = kmod
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
- provides = kernel26-mainline=4.1rc8
+ provides = kernel26-mainline=4.1
conflicts = kernel26-mainline
replaces = kernel26-mainline
backup = etc/mkinitcpio.d/linux-mainline.preset
pkgname = linux-mainline-headers
pkgdesc = Header files and scripts for building modules for Linux-mainline kernel
- provides = kernel26-mainline-headers=4.1rc8
+ provides = kernel26-mainline-headers=4.1
conflicts = kernel26-mainline-headers
replaces = kernel26-mainline-headers
pkgname = linux-mainline-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-mainline kernel
- provides = kernel26-mainline-docs=4.1rc8
+ provides = kernel26-mainline-docs=4.1
conflicts = kernel26-mainline-docs
replaces = kernel26-mainline-docs
diff --git a/PKGBUILD b/PKGBUILD
index 5773932cf226..9c0531750dd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgbase=linux-mainline # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
-_srcname=linux-4.0
+_srcname=linux-4.1
_patchname=patch-4.1-rc8
-pkgver=4.1rc8
+pkgver=4.1
pkgrel=1
arch=('i686' 'x86_64')
url="https://imasheep.hurrdurr.org/"
@@ -14,7 +14,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
+ #"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_patchname}.xz"
#"https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.sign"
#"https://www.kernel.org/pub/linux/kernel/v3.x/testing/${_patchname}.sign"
# the main kernel config files
@@ -23,8 +23,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'change-default-console-loglevel.patch'
)
-sha256sums=('0f2f7d44979bc8f71c4fc5d3308c03499c26a824dd311fdf6eef4dee0d7d5991'
- 'dad6572b2e806bf0efbd6920c2a37aa3ba0349225eab85f7dcbc2de34399ec99'
+sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'514aa8a9d03d2419c8084725fcdb2b5b4ce07966f5bd6a51224a5f7a5f8c3694'
'b268b03a042e3f604a12a80c6e24c42006e4d9bf4a6d9b3201eb006942718128'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
@@ -39,7 +38,7 @@ _kernelname=${pkgbase#linux}
prepare() {
cd "${srcdir}/${_srcname}"
- patch -p1 -i "${srcdir}/${_patchname}"
+ #patch -p1 -i "${srcdir}/${_patchname}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git