summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSid2021-09-18 17:29:28 +0530
committerSid2021-09-18 17:29:28 +0530
commit70621780793fd5a65d2c7268717cafdb0d281681 (patch)
tree95748b41ebf9cae1f36e3aa3b0b138489046b939
parentd1b259734b677390e8a569f3118f577e892bd7d5 (diff)
downloadaur-70621780793fd5a65d2c7268717cafdb0d281681.tar.gz
Revert previous commit and fix pkgdesc
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2458940cbaf7..a4984cf34328 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-mainline-anbox
- pkgdesc = Linux Mainline with ashmem and binder modules enabled
+ pkgdesc = Linux Mainline
pkgver = 5.15rc1
pkgrel = 1
url = https://kernel.org/
@@ -29,7 +29,7 @@ pkgbase = linux-mainline-anbox
sha256sums = 5cdca495212b2986c8ff9d1b0cd87f2d344a880c09237f062699385c9bbedf80
pkgname = linux-mainline-anbox
- pkgdesc = The Linux Mainline with ashmem and binder modules enabled kernel and modules
+ pkgdesc = The Linux Mainline kernel and modules with ashmem and binder enabled
depends = coreutils
depends = kmod
depends = initramfs
@@ -37,15 +37,12 @@ pkgname = linux-mainline-anbox
optdepends = linux-firmware: firmware images needed for some devices
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- provides = linux-mainline
replaces = virtualbox-guest-modules-mainline
replaces = wireguard-maineline
pkgname = linux-mainline-anbox-headers
- pkgdesc = Headers and scripts for building modules for the Linux Mainline with ashmem and binder modules enabled kernel
+ pkgdesc = Headers and scripts for building modules for the Linux Mainline kernel
depends = pahole
- provides = linux-mainline-headers
pkgname = linux-mainline-anbox-docs
- pkgdesc = Documentation for the Linux Mainline with ashmem and binder modules enabled kernel
- provides = linux-mainline-docs
+ pkgdesc = Documentation for the Linux Mainline kernel
diff --git a/PKGBUILD b/PKGBUILD
index 21dce630020f..1b6d856c6970 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgbase=linux-mainline-anbox # Build stock -ARCH kernel
_tag=v5.15-rc1
pkgver=5.15rc1
pkgrel=1
-pkgdesc="Linux Mainline with ashmem and binder modules enabled"
+pkgdesc="Linux Mainline"
arch=(x86_64)
url="https://kernel.org/"
license=(GPL2)
@@ -71,11 +71,11 @@ build() {
}
_package() {
- pkgdesc="The $pkgdesc kernel and modules"
+ pkgdesc="The $pkgdesc kernel and modules with ashmem and binder enabled"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE linux-mainline)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-mainline wireguard-maineline)
cd $_srcname
@@ -99,7 +99,6 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
- provides=(linux-mainline-headers)
depends=(pahole)
cd $_srcname
@@ -182,7 +181,6 @@ _package-headers() {
_package-docs() {
pkgdesc="Documentation for the $pkgdesc kernel"
- provides=(linux-mainline-docs)
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"