summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenny Strawn2022-03-27 17:20:20 -0700
committerKenny Strawn2022-03-27 17:20:20 -0700
commita2a9296a0d3d3ae24458383a568ab42f36ad2a2f (patch)
tree4dec1775134fa640a06d3cb050c52d67ad0c0dc4
parent41bef322698146511f33f0be4509e354b007a769 (diff)
downloadaur-a2a9296a0d3d3ae24458383a568ab42f36ad2a2f.tar.gz
Fix conflicts
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304902f99059..05f7dd67a96a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,6 @@ pkgbase = linux-mainline-anbox-git
makedepends = python-sphinx_rtd_theme
makedepends = graphviz
makedepends = imagemagick
- provides = linux-mainline-anbox
- conflicts = linux-mainline-anbox
options = !strip
source = linux-mainline-anbox::git+https://github.com/torvalds/linux
source = config
@@ -33,11 +31,14 @@ pkgname = linux-mainline-anbox-git
optdepends = linux-firmware: firmware images needed for some devices
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
+ conflicts = linux-mainline-anbox
replaces = virtualbox-guest-modules-mainline
replaces = wireguard-mainline
pkgname = linux-mainline-anbox-git-headers
pkgdesc = Headers and scripts for building modules for the Linux Mainline kernel
+ conflicts = linux-mainline-anbox-headers
pkgname = linux-mainline-anbox-git-docs
pkgdesc = Documentation for the Linux Mainline kernel
+ conflicts = linux-mainline-anbox-docs
diff --git a/PKGBUILD b/PKGBUILD
index e4e429123a4c..f2463a34bf1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,6 @@ makedepends=(
cpio bc kmod libelf git pahole
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
-provides=(linux-mainline-anbox)
-conflicts=(linux-mainline-anbox)
options=('!strip')
_srcname=linux-mainline-anbox
source=(
@@ -73,6 +71,7 @@ _package() {
'linux-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-mainline wireguard-mainline)
+ conflicts=(linux-mainline-anbox)
cd $_srcname
local kernver="$(<version)"
@@ -95,6 +94,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ conflicts=(linux-mainline-anbox-headers)
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -176,6 +176,7 @@ _package-headers() {
_package-docs() {
pkgdesc="Documentation for the $pkgdesc kernel"
+ conflicts=(linux-mainline-anbox-docs)
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"