summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenny Strawn2022-03-27 15:21:00 -0700
committerKenny Strawn2022-03-27 15:21:00 -0700
commita97a0a1800d25f823f923fdc44fda0efed0cc4d6 (patch)
treefcfb46389317d1b94b6150924b29b7ae5b7a894f
parentc07c0b11c35543540de7a6fa80d49797f2569670 (diff)
downloadaur-a97a0a1800d25f823f923fdc44fda0efed0cc4d6.tar.gz
Update PKGBUILD to match upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b288cdcb1867..31ac0753ab1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,8 +29,10 @@ pkgname = linux-mainline-anbox-git
depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
+ provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- replaces = wireguard-arch
+ replaces = virtualbox-guest-modules-mainline
+ replaces = wireguard-mainline
pkgname = linux-mainline-anbox-git-headers
pkgdesc = Headers and scripts for building modules for the Linux Mainline kernel
diff --git a/PKGBUILD b/PKGBUILD
index 35cd78927b4c..2d0148762ed7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,8 +68,8 @@ _package() {
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(WIREGUARD-MODULE)
- replaces=(wireguard-arch)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ replaces=(virtualbox-guest-modules-mainline wireguard-mainline)
cd $_srcname
local kernver="$(<version)"
@@ -103,11 +103,11 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -117,14 +117,17 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;