summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsayad2021-01-26 12:36:15 +0600
committersayad2021-01-26 12:36:15 +0600
commit58d0d810a917e05e718b68de1e9e4b6c0738e0dd (patch)
tree972c8acb4818285327f51d5fd67d913f029219b2
parentc79002903ee61ad94bc3810ae2f21e5a549b92d4 (diff)
downloadaur-58d0d810a917e05e718b68de1e9e4b6c0738e0dd.tar.gz
Bug fix
-rw-r--r--customization.cfg2
-rw-r--r--prepare129
2 files changed, 2 insertions, 129 deletions
diff --git a/customization.cfg b/customization.cfg
index b8d57e1e4cf6..1fc4e8b13306 100644
--- a/customization.cfg
+++ b/customization.cfg
@@ -3,7 +3,7 @@
# Linux distribution you are using, options are "Arch", "Void", "Ubuntu", "Debian", "Fedora" or "Suse".
# It is automatically set to "Arch" when using PKGBUILD.
# If left empty, the script will prompt
-_distro=""
+_distro="Arch"
# Kernel Version - Options are "5.4", "5.7", "5.8", "5.9", "5.10"
_version="5.10"
diff --git a/prepare b/prepare
index 7d7f44efa2d4..b686fa08f318 100644
--- a/prepare
+++ b/prepare
@@ -13,105 +13,15 @@ _tkg_initscript() {
source "$_EXT_CONFIG_PATH" && msg2 "External configuration file $_EXT_CONFIG_PATH will be used to override customization.cfg values.\n"
fi
- # Default to Arch
- if [ -z "$_distro" ] || [ "$_ispkgbuild" = "true" ]; then
- msg2 "Defaulting to Archlinux target\n"
- _distro="Arch"
- fi
-
- # create build dir early
- if [ "$_distro" = "Void" ]; then
- _path="${XBPS_BUILDDIR}/${wrksrc}"
- else
- _path="${_where}"
- fi
-
- if [ -z "$_version" ] && [ ! -e "$_path"/versel ]; then
- plain "Which kernel version do you want to install?"
- read -rp "`echo $' 1. 5.4 LTS\n 2. 5.7\n 3. 5.8\n 4. 5.9\n > 5. 5.10\n 6. 5.11 RC\nchoice[1-6?]'`" _VERSEL;
- case $_VERSEL in
- "1")
- echo "_basever=54" > "$_path"/versel
- echo "_basekernel=5.4" >> "$_path"/versel
- echo "_sub=${ver54}" >> "$_path"/versel
- ;;
- "2")
- echo "_basever=57" > "$_path"/versel
- echo "_basekernel=5.7" >> "$_path"/versel
- echo "_sub=${ver57}" >> "$_path"/versel
- ;;
- "3")
- echo "_basever=58" > "$_path"/versel
- echo "_basekernel=5.8" >> "$_path"/versel
- echo "_sub=${ver58}" >> "$_path"/versel
- ;;
- "4")
- echo "_basever=59" > "$_path"/versel
- echo "_basekernel=5.9" >> "$_path"/versel
- echo "_sub=${ver59}" >> "$_path"/versel
- ;;
- "6")
- echo "_basever=511" > "$_path"/versel
- echo "_basekernel=5.11" >> "$_path"/versel
- echo "_sub=${ver511}" >> "$_path"/versel
- ;;
- *)
echo "_basever=510" > "$_path"/versel
echo "_basekernel=5.10" >> "$_path"/versel
echo "_sub=${ver510}" >> "$_path"/versel
- ;;
- esac
- elif [ -n "$_version" ];then
- case "$_version" in
- "5.4")
- echo "_basever=54" > "$_path"/versel
- echo "_basekernel=5.4" >> "$_path"/versel
- echo "_sub=${ver54}" >> "$_path"/versel
- ;;
- "5.7")
- echo "_basever=57" > "$_path"/versel
- echo "_basekernel=5.7" >> "$_path"/versel
- echo "_sub=${ver57}" >> "$_path"/versel
- ;;
- "5.8")
- echo "_basever=58" > "$_path"/versel
- echo "_basekernel=5.8" >> "$_path"/versel
- echo "_sub=${ver58}" >> "$_path"/versel
- ;;
- "5.9")
- echo "_basever=59" > "$_path"/versel
- echo "_basekernel=5.9" >> "$_path"/versel
- echo "_sub=${ver59}" >> "$_path"/versel
- ;;
- "5.10")
- echo "_basever=510" > "$_path"/versel
- echo "_basekernel=5.10" >> "$_path"/versel
- echo "_sub=${ver510}" >> "$_path"/versel
- ;;
- "5.11")
- echo "_basever=511" > "$_path"/versel
- echo "_basekernel=5.11" >> "$_path"/versel
- echo "_sub=${ver511}" >> "$_path"/versel
- ;;
- *)
- error "There is something wrong with your kernel version selection, exiting..."
- exit 1
- esac
- fi
# source versel early if present
if [ -e "${_path}"/versel ]; then
source "${_path}"/versel
fi
- # if [ "$_distro" != "Void" ]; then
- # cp "$_where"/${_basekernel}/* "$_where" # copy patches inside the PKGBUILD's dir to preserve makepkg sourcing and md5sum checking
- # cp "$_where"/${_basekernel}/* "$_where" # copy config files and hooks inside the PKGBUILD's dir to preserve makepkg sourcing and md5sum checking
- # else
- # cp "$_where"/${_basekernel}/* "$_path"
- # cp "$_where"/${_basekernel}/* "$_path"
- # fi
-
if [ -z "$_OPTIPROFILE" ] && [ ! -e "$_path"/cpuschedset ]; then
# Prompt about optimized configurations. Available variable values will overwrite customization.cfg/external config ones.
plain "Do you want to use a predefined optimized profile?"
@@ -206,11 +116,6 @@ _tkg_initscript() {
echo "_custom_pkgbase=\"${_custom_pkgbase}\"" >> "${_path}"/cpuschedset
fi
- if [ "$_basever" = "511" ] && [ "$_cpusched" != "cfs" ]; then
- warning "No support for alternative CPU schedulers on this kernel version. Defaulting to CFS."
- echo "_cpusched=\"cfs\"" > "${_path}"/cpuschedset
- fi
-
case $_compileroptlevel in
"2")
_compileropt="-O3"
@@ -324,10 +229,6 @@ _tkg_patcher() {
_tkg_srcprep() {
- if [ "${_distro}" = "Void" ] && [ -e ${srcdir}/sum_failed ]; then
- exit 1
- fi
-
if [ "${_distro}" = "Arch" ]; then
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
@@ -350,13 +251,6 @@ _tkg_srcprep() {
fi
fi
- # Void
- if [ "$_distro" = "Void" ] && [[ "$_sub" = rc* ]]; then
- cd ${wrksrc}/linux-${_rc_kern_ver}
- elif [ "$_distro" = "Void" ]; then
- cd ${wrksrc}/linux-${_kern_ver}
- fi
-
# graysky's cpu opts - https://github.com/graysky2/kernel_gcc_patch
if [ "$_compiler_name" != "-llvm" ]; then
msg2 "Applying graysky's cpu opts patch"
@@ -390,15 +284,8 @@ _tkg_srcprep() {
fi
# prjc/bmq patch rev
- if [ "$_basever" = "58" ] || [ "$_basever" = "57" ]; then
- rev=3
- elif [ "$_basever" = "59" ]; then
- rev=3
- elif [ "$_basever" = "510" ]; then
+ if [ "$_basever" = "510" ]; then
rev=2
- else
- rev=0
- fi
if [ "${_cpusched}" = "MuQSS" ]; then
# MuQSS
@@ -461,12 +348,6 @@ _tkg_srcprep() {
tkgpatch="$srcdir/0003-glitched-cfs.patch" && _tkg_patcher
fi
- if [ "$_distro" = "Void" ] && [[ "$_sub" = rc* ]]; then
- cd ${wrksrc}/linux-${_rc_kern_ver}
- elif [ "$_distro" = "Void" ] && [[ "$_sub" != rc* ]]; then
- cd ${wrksrc}/linux-${_kern_ver}
- fi
-
if [ "${_distro}" = "Arch" ] || [ "$_distro" = "Void" ]; then
if [ -z "${_configfile}" ]; then
_configfile="config.x86_64"
@@ -1273,14 +1154,6 @@ exit_cleanup() {
rm -f "$_where"/compilerset
rm -f "$_where"/versel
- # Remove temporarily copied files
-# rm -rf "$_where"/*.patch
-# rm -rf "$_where"/*-profile.cfg
-# rm -f "$_where"/config*
-# rm -f "$_where"/*.hook
-# rm -f "$_where"/cleanup
-# rm -f "$_where"/prepare
-
# Community patches removal in case of failure
for _p in ${_community_patches[@]}; do
rm -f "$_where"/linux"$_basever"-tkg-userpatches/"$_p"