summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsayad2021-01-28 20:59:22 +0600
committersayad2021-01-28 20:59:22 +0600
commitf68e545e0b8e5349ffa2b54eb16fa51fdde9948d (patch)
tree475b1736ba66021c2d218a8ad3e01d5a71f1d59c
parent0a85c33f3e79dbfd213afe2ed1b421c267c2415e (diff)
downloadaur-f68e545e0b8e5349ffa2b54eb16fa51fdde9948d.tar.gz
Bug fix
-rw-r--r--PKGBUILD13
-rw-r--r--customization.cfg9
-rw-r--r--prepare18
3 files changed, 30 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7a71dece7bb..6c813892a043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,14 @@ source "$_where"/prepare
_tkg_initscript
-#if [[ "$_sub" = rc* ]]; then
-# _srcpath="linux-${_basekernel}-${_sub}"
-# kernel_site="https://git.kernel.org/torvalds/t/linux-${_basekernel}-${_sub}.tar.gz"
-#else
+if [[ "$_sub" = rc* ]]; then
+ _srcpath="linux-${_basekernel}-${_sub}"
+ kernel_site="https://git.kernel.org/torvalds/t/linux-${_basekernel}-${_sub}.tar.gz"
+else
_srcpath="linux-${_basekernel}"
kernel_site="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.xz"
patch_site="https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${_basekernel}.${_sub}.xz"
-#fi
+fi
#_srcpath="bcachefs"
#kernel_site="git+https://github.com/koverstreet/bcachefs.git"
@@ -76,8 +76,7 @@ options=('!strip' 'docs')
"https://raw.githubusercontent.com/Frogging-Family/linux-tkg/master/linux-tkg-patches/5.10/0012-linux-hardened.patch"
"https://raw.githubusercontent.com/Frogging-Family/linux-tkg/master/linux-tkg-patches/5.10/0012-misc-additions.patch"
)
-
-sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
+ sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
'ac108b5a3a1539e72ced4dda6d4da63c0b488b7905a554cf062b8b4c187cab6e'
'SKIP'
'458d1ca195f3fee5501683a4b61ef0ed0cfa7e5219eccab3390fb40c0289898a'
diff --git a/customization.cfg b/customization.cfg
index f8727b8c24b6..7fa00b1a414d 100644
--- a/customization.cfg
+++ b/customization.cfg
@@ -11,7 +11,7 @@ _version="5.10"
#### MISC OPTIONS ####
# External config file to use - If the given file exists in path, it will override default config (customization.cfg) - Default is ~/.config/frogminer/linux-tkg.cfg
-_EXT_CONFIG_PATH="~/.config/linux-tkg.cfg"
+_EXT_CONFIG_PATH=~/.config/linux-tkg.cfg
# [Arch specific] Set to anything else than "true" to limit cleanup operations and keep source and files generated during compilation.
# Default is "true".
@@ -60,6 +60,9 @@ _configfile=""
# Disable some non-module debugging - See PKGBUILD for the list
_debugdisable="false"
+# Set to true to enable CONFIG_EXPERT - No need to enable it if you don't know you need it
+_config_expert="false"
+
# LEAVE AN EMPTY VALUE TO BE PROMPTED ABOUT FOLLOWING OPTIONS AT BUILD TIME
# CPU scheduler - Options are "upds" (TkG's Undead PDS), "pds", "bmq", "muqss" or "cfs"
@@ -182,8 +185,8 @@ _kernel_localversion=""
# example: _community_patches="clear_nack_in_tend_isr.myrevert ffb_regression_fix.mypatch 0008-drm-amd-powerplay-force-the-trim-of-the-mclk-dpm-levels-if-OD-is-enabled.mypatch"
_community_patches="futex2_interface.mypatch RDTSC-KVM-Handler.mypatch"
-# You can use your own patches by putting them in the same folder as the PKGBUILD and giving them the .mypatch extension.
-# You can also revert patches by putting them in the same folder as the PKGBUILD and giving them the .myrevert extension.
+# You can use your own patches by putting them in a subfolder called linux<version>-tkg-userpatches (e.g. linux510-tkg-userpatches) next to the PKGBUILD and giving them the .mypatch extension.
+# You can also revert patches by putting them in that same folder and giving them the .myrevert extension.
# Also, userpatches variable below must be set to true for the above to work.
_user_patches="true"
diff --git a/prepare b/prepare
index c12bc9e2b6f7..60db4015fb1a 100644
--- a/prepare
+++ b/prepare
@@ -13,13 +13,23 @@ _tkg_initscript() {
source "$_EXT_CONFIG_PATH" && msg2 "External configuration file $_EXT_CONFIG_PATH will be used to override customization.cfg values.\n"
fi
+ # Default to Arch
+ if [ -z "$_distro" ] || [ "$_ispkgbuild" = "true" ]; then
+ msg2 "Defaulting to Archlinux target\n"
+ _distro="Arch"
+ fi
+
# create build dir early
_path="${_where}"
if [ -z "$_version" ] && [ ! -e "$_path"/versel ]; then
+ case $_VERSEL in
+ *)
echo "_basever=510" > "$_path"/versel
echo "_basekernel=5.10" >> "$_path"/versel
echo "_sub=${ver510}" >> "$_path"/versel
+ ;;
+ esac
elif [ -n "$_version" ];then
case "$_version" in
"5.10")
@@ -389,6 +399,14 @@ _tkg_srcprep() {
fi
fi
+ if [ "$_compiler_name" = "-llvm" ]; then
+ echo 'CONFIG_KCSAN=n' >> ./.config
+ echo 'CONFIG_INIT_STACK_ALL=n' >> ./.config
+ sed -i -e 's/# CONFIG_INIT_ON_FREE_DEFAULT_ON is not set/CONFIG_INIT_ON_FREE_DEFAULT_ON=y/' ./.config
+ sed -i -e 's/CONFIG_INIT_STACK_NONE=y/CONFIG_INIT_STACK_NONE=n/' ./.config
+ echo "CONFIG_INIT_STACK_ALL_ZERO=y" >> ./.config
+ fi
+
if [ "$_font_autoselect" != "false" ]; then
sed -i -e 's/CONFIG_FONT_TER16x32=y/# CONFIG_FONT_TER16x32 is not set\nCONFIG_FONT_AUTOSELECT=y/' ./.config
fi