summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-11-17 07:02:44 +1000
committerKyle De'Vir2018-11-17 07:02:44 +1000
commit357aeb4a2afdc02c3da30a189dc580924632a018 (patch)
treed1ebdeafb53270fb202173b589dccd84495ad332
parent1c5de7cc0e3ff75aba1eb41c057f1b1f6cbb29a8 (diff)
downloadaur-357aeb4a2afdc02c3da30a189dc580924632a018.tar.gz
Changes
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xconfig (renamed from config.x86_64)0
-rw-r--r--linux.install.pkg10
4 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abdcbe82edca..7b3425527158 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,7 @@ pkgbase = linux-bcachefs-git
options = !strip
source = git+https://evilpiepirate.org/git/bcachefs.git
source = git+https://evilpiepirate.org/git/bcachefs-tools.git
- source = config.x86_64
+ source = config
source = linux-bcachefs-git.preset
sha256sums = SKIP
sha256sums = SKIP
@@ -44,5 +44,7 @@ pkgname = linux-bcachefs-git-docs
provides = linux-bcachefs-docs
pkgname = linux-bcachefs-git-tools
+ pkgdesc = Bcachefs filesystem utilities
+ install = linux.install.pkg
provides = bcachefs-tools
diff --git a/PKGBUILD b/PKGBUILD
index dc2594a50bd0..d45fccf4345e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ options=('!strip')
source=('git+https://evilpiepirate.org/git/bcachefs.git'
'git+https://evilpiepirate.org/git/bcachefs-tools.git'
# the main kernel config files
- 'config.x86_64'
+ 'config'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset")
sha256sums=('SKIP'
diff --git a/config.x86_64 b/config
index 53c348b9f375..53c348b9f375 100755
--- a/config.x86_64
+++ b/config
diff --git a/linux.install.pkg b/linux.install.pkg
new file mode 100644
index 000000000000..6b84718eecdd
--- /dev/null
+++ b/linux.install.pkg
@@ -0,0 +1,10 @@
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+}
+
+post_remove() {
+ rm -f boot/initramfs-linux-zen-bcachefs.img
+ rm -f boot/initramfs-linux-zen-bcachefs-fallback.img
+}