summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-12-06 16:03:13 +1000
committerKyle De'Vir2018-12-06 16:03:13 +1000
commit9c720e8b544f746a3351997c82fd45bdd928b1fb (patch)
tree5704a7057429b1efe6444f312b5293e67499d25e
parentb7fd671dce9387b7a5b0fdd86f81c6399ee25e47 (diff)
downloadaur-9c720e8b544f746a3351997c82fd45bdd928b1fb.tar.gz
Remove ext4 patch, as it is provided by Arch Linux
-rwxr-xr-x.SRCINFO1
-rwxr-xr-xPKGBUILD1
-rw-r--r--ext4-corruption-patch.patch52
3 files changed, 0 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5173303e3590..2b69abdf9468 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,6 @@ pkgbase = linux-bcachefs-git
source = 60-linux.hook
source = 90-linux.hook
source = linux.preset
- source = ext4-corruption-patch.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c053647162ef..21d97addb10b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,6 @@ source=(
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
- ext4-corruption-patch.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
diff --git a/ext4-corruption-patch.patch b/ext4-corruption-patch.patch
deleted file mode 100644
index b058e39909ef..000000000000
--- a/ext4-corruption-patch.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From: Jens Axboe <axboe@kernel.dk>
-Subject: [PATCH] blk-mq: fix corruption with direct issue
-
-If we attempt a direct issue to a SCSI device, and it returns BUSY, then
-we queue the request up normally. However, the SCSI layer may have
-already setup SG tables etc for this particular command. If we later
-merge with this request, then the old tables are no longer valid. Once
-we issue the IO, we only read/write the original part of the request,
-not the new state of it.
-
-This causes data corruption, and is most often noticed with the file
-system complaining about the just read data being invalid:
-
-[ 235.934465] EXT4-fs error (device sda1): ext4_iget:4831: inode #7142: comm dpkg-query: bad extra_isize 24937 (inode size 256)
-
-because most of it is garbage...
-
-This doesn't happen from the normal issue path, as we will simply defer
-the request to the hardware queue dispatch list if we fail. Once it's on
-the dispatch list, we never merge with it.
-
-Fix this from the direct issue path by flagging the request as
-REQ_NOMERGE so we don't change the size of it before issue.
-
-See also:
- https://bugzilla.kernel.org/show_bug.cgi?id=201685
-
-Fixes: 6ce3dd6eec1 ("blk-mq: issue directly if hw queue isn't busy in case of 'none'")
-Signed-off-by: Jens Axboe <axboe@kernel.dk>
-
----
-
-diff --git a/block/blk-mq.c b/block/blk-mq.c
-index 3f91c6e5b17a..d8f518c6ea38 100644
---- a/block/blk-mq.c
-+++ b/block/blk-mq.c
-@@ -1715,6 +1715,15 @@ static blk_status_t __blk_mq_issue_directly(struct blk_mq_hw_ctx *hctx,
- break;
- case BLK_STS_RESOURCE:
- case BLK_STS_DEV_RESOURCE:
-+ /*
-+ * If direct dispatch fails, we cannot allow any merging on
-+ * this IO. Drivers (like SCSI) may have set up permanent state
-+ * for this request, like SG tables and mappings, and if we
-+ * merge to it later on then we'll still only do IO to the
-+ * original part.
-+ */
-+ rq->cmd_flags |= REQ_NOMERGE;
-+
- blk_mq_update_dispatch_busy(hctx, true);
- __blk_mq_requeue_request(rq);
- break;