summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-05-14 19:52:37 +1000
committerKyle De'Vir2019-05-14 19:52:37 +1000
commiteff48e3984dceb23eab231def4843a2fb52d7c6f (patch)
tree79b03131ff771820e4d073b2c23fd384d1821dfd
parent319002d03c469afc66603bfecad32fc51e53ca17 (diff)
downloadaur-eff48e3984dceb23eab231def4843a2fb52d7c6f.tar.gz
Update
-rwxr-xr-x.SRCINFO18
-rwxr-xr-xPKGBUILD37
2 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df50af5c1b7b..f75217b4496f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,15 +19,15 @@ pkgbase = linux-bcachefs-git
source = linux.preset
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 408d92182111c3ae9f54f6e166e6175de3c10faa63bda59f2160fbdfd526ac03
- sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
- sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 408d92182111c3ae9f54f6e166e6175de3c10faa63bda59f2160fbdfd526ac03
+ sha512sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
+ sha512sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
+ sha512sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-bcachefs-git
- pkgdesc = The Linux-bcachefs-git kernel and modules
+ pkgdesc = The Linux-bcachefs-git kernel and modules ~ featuring Kent Overstreet's bcachefs filesystem
install = linux.install
depends = bcachefs-tools-git
depends = coreutils
@@ -38,12 +38,12 @@ pkgname = linux-bcachefs-git
backup = etc/mkinitcpio.d/linux-bcachefs-git.preset
pkgname = linux-bcachefs-git-headers
- pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel
+ pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
provides = linux-bcachefs-git-headers=5.0.15.arch1
provides = linux-headers=5.0.15.arch1
pkgname = linux-bcachefs-git-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel
+ pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
provides = linux-bcachefs-git-docs=5.0.15.arch1
provides = linux-docs=5.0.15.arch1
diff --git a/PKGBUILD b/PKGBUILD
index d8a18d98d8a4..76d12299c2f6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,17 +82,21 @@ _reponame_gcc_patch="kernel_gcc_patch"
_repo_url_gcc_patch="https://github.com/graysky2/${_reponame_gcc_patch}"
_gcc_patch_name="enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch"
-source=("git+${_repo_url}#branch=master"
- "git+${_repo_url_gcc_patch}"
- config # the main kernel config file
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
+_pkgdesc_extra="~ featuring Kent Overstreet's bcachefs filesystem"
+
+source=(
+ "git+${_repo_url}#branch=master"
+ "git+${_repo_url_gcc_patch}"
+ config # the main kernel config file
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
)
-validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('SKIP'
+sha512sums=('SKIP'
'SKIP'
'408d92182111c3ae9f54f6e166e6175de3c10faa63bda59f2160fbdfd526ac03'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
@@ -125,15 +129,6 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "$_kernelname" > localversion.20-pkgname
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
- done
-
msg2 "Setting config..."
cp ../config .config
@@ -175,7 +170,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules ${_pkgdesc_extra}"
depends=(
bcachefs-tools-git
coreutils
@@ -236,7 +231,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel ${_pkgdesc_extra}"
provides=(
"linux-bcachefs-git-headers=${pkgver}"
"linux-headers=${pkgver}"
@@ -321,7 +316,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel ${_pkgdesc_extra}"
provides=(
"linux-bcachefs-git-docs=${pkgver}"
"linux-docs=${pkgver}"