summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHikari Hayashi2022-08-03 20:48:18 +0800
committerHikari Hayashi2022-08-03 20:55:23 +0800
commit690811f8682a1caed65b161944e8d6e1d16f5244 (patch)
treee34e6a5fc4d3e4a95f10251891ac67de6bea89bc
parent026e68368e444797365ed54ec4bce55fcb140916 (diff)
downloadaur-690811f8682a1caed65b161944e8d6e1d16f5244.tar.gz
Do not build the docs package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 2 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c0e0ccde5bb..edd4234b8f3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -51,6 +51,3 @@ pkgname = linux-mainline-um5302ta
pkgname = linux-mainline-um5302ta-headers
pkgdesc = Headers and scripts for building modules for the Linux kernel
depends = pahole
-
-pkgname = linux-mainline-um5302ta-docs
- pkgdesc = Documentation for the Linux kernel
diff --git a/PKGBUILD b/PKGBUILD
index 6277e3813ed5..5ae7010263eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,7 +68,7 @@ prepare() {
build() {
cd $_srcname
- make htmldocs all
+ make all
}
_package() {
@@ -181,26 +181,7 @@ _package-headers() {
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
-_package-docs() {
- pkgdesc="Documentation for the $pkgdesc kernel"
-
- cd $_srcname
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- echo "Installing documentation..."
- local src dst
- while read -rd '' src; do
- dst="${src#Documentation/}"
- dst="$builddir/Documentation/${dst#output/}"
- install -Dm644 "$src" "$dst"
- done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
-
- echo "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-}
-
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")