summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorANDRoid78902021-09-13 12:12:04 +0400
committerANDRoid78902021-09-13 12:12:04 +0400
commitc04d0b3b19eff215acd9bae4019773719ba78030 (patch)
tree5216b098f058b31aa1ef8685db602a010a576760
parent86bacb966beef03262c1cee0710040ed0732a20f (diff)
downloadaur-c04d0b3b19eff215acd9bae4019773719ba78030.tar.gz
5.10.64
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4e0e24e95eb..89967be09a34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-manjaro-xanmod-lts
pkgdesc = Linux Xanmod LTS
- pkgver = 5.10.52
+ pkgver = 5.10.64
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -19,16 +19,16 @@ pkgbase = linux-manjaro-xanmod-lts
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.10.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.10.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.10.52-xanmod1/patch-5.10.52-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.10.64-xanmod1/patch-5.10.64-xanmod1.xz
source = choose-gcc-optimization.sh
- source = https://gitlab.manjaro.org/packages/core/linux510/-/archive/571b7550ed563891bd4cb4c21bf1b4e76132cee4/linux510-571b7550ed563891bd4cb4c21bf1b4e76132cee4.tar.gz
+ source = https://gitlab.manjaro.org/packages/core/linux510/-/archive/4e18ce491dc816d725524039cdbb8ca448b1bef9/linux510-4e18ce491dc816d725524039cdbb8ca448b1bef9.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43
sha256sums = SKIP
- sha256sums = 58ae5190fe3331a20c052d0043e712b6e75f666c86514cb2e37bf42eb5afa4b2
+ sha256sums = 833e6b3ae9e058f1e93f4d364198563d7ec692b1aac2cc33c4cf7f7f03f8edea
sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
- sha256sums = f178d20aaceb147412170f4cb9d256e7f193eb86e7993d7858d3ca4fd5c75862
+ sha256sums = 20cb06b53000bf3b6852fba9bc3d7ce119569b83adca40565203e2e045350487
pkgname = linux-manjaro-xanmod-lts
pkgdesc = The Linux LTS kernel and modules with Xanmod and Manjaro patches (Bootsplash support)
diff --git a/PKGBUILD b/PKGBUILD
index e9208e7b3f65..7699651a232e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,7 +70,7 @@ _makenconfig=
pkgbase=linux-manjaro-xanmod-lts
pkgname=("${pkgbase}" "${pkgbase}-headers")
_major=5.10
-pkgver=${_major}.52
+pkgver=${_major}.64
_branch=5.x
xanmod=1
pkgrel=1
@@ -78,7 +78,7 @@ pkgdesc='Linux Xanmod LTS'
url="http://www.xanmod.org/"
arch=(x86_64)
-__commit="571b7550ed563891bd4cb4c21bf1b4e76132cee4" # 5.10.52-1
+__commit="4e18ce491dc816d725524039cdbb8ca448b1bef9" # 5.10.64-1
license=(GPL2)
makedepends=(
@@ -98,9 +98,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
"https://gitlab.manjaro.org/packages/core/linux510/-/archive/${__commit}/linux510-${__commit}.tar.gz")
sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43' # linux-5.4.tar.xz
'SKIP' # .sign
- '58ae5190fe3331a20c052d0043e712b6e75f666c86514cb2e37bf42eb5afa4b2' # xanmod
+ '833e6b3ae9e058f1e93f4d364198563d7ec692b1aac2cc33c4cf7f7f03f8edea' # xanmod
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee' # choose-gcc-optimization.sh
- 'f178d20aaceb147412170f4cb9d256e7f193eb86e7993d7858d3ca4fd5c75862') # manjaro
+ '20cb06b53000bf3b6852fba9bc3d7ce119569b83adca40565203e2e045350487') # manjaro
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -142,6 +142,8 @@ prepare() {
# Manjaro patches
rm ../linux510-$__commit/0103-futex.patch # remove conflicting patches
rm ../linux510-$__commit/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
+ rm ../linux510-$__commit/0105-ucsi-acpi.patch
+ rm ../linux510-$__commit/0106-ucsi.patch
local _patch
for _patch in ../linux510-$__commit/*; do
@@ -220,7 +222,7 @@ prepare() {
make LLVM=$_LLVM LLVM_IAS=$_LLVM LSMOD=$HOME/.config/modprobed.db localmodconfig
else
msg2 "No modprobed.db data found"
- exit
+ exit 1
fi
fi