summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-06-04 18:03:06 +0300
committerIgor Dyatlov2021-06-04 18:03:06 +0300
commit641394301a5e738cec427f892f2e4bbd2d5a4410 (patch)
tree16f5904524580602a4869b29d3cb00196e7e79d7
parent2bd01b3fc56a11698e109aa3173e7b91de80e88f (diff)
downloadaur-641394301a5e738cec427f892f2e4bbd2d5a4410.tar.gz
Fix GCC
-rw-r--r--PKGBUILD53
1 files changed, 30 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78fd9f96043a..b2bb156351bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _makenconfig=y
_enable_gcc_more_v="y"
# Optionally select a sub architecture by number or leave blank which will
# require user interaction during the build. Note that the generic (default)
-# option is 32.
+# option is 36.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -24,29 +24,36 @@ _enable_gcc_more_v="y"
# 10. AMD Excavator (MEXCAVATOR)
# 11. AMD Zen (MZEN)
# 12. AMD Zen 2 (MZEN2)
-# 13. Intel P4 / older Netburst based Xeon (MPSC)
-# 14. Intel Atom (MATOM)
+# 13. AMD Zen 3 (MZEN3)
+# 14. Intel P4 / older Netburst based Xeon (MPSC)
# 15. Intel Core 2 (MCORE2)
-# 16. Intel Nehalem (MNEHALEM)
-# 17. Intel Westmere (MWESTMERE)
-# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Goldmont (MGOLDMONT)
-# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 21. Intel Sandy Bridge (MSANDYBRIDGE)
-# 22. Intel Ivy Bridge (MIVYBRIDGE)
-# 23. Intel Haswell (MHASWELL)
-# 24. Intel Broadwell (MBROADWELL)
-# 25. Intel Skylake (MSKYLAKE)
-# 26. Intel Skylake X (MSKYLAKEX)
-# 27. Intel Cannon Lake (MCANNONLAKE)
-# 28. Intel Ice Lake (MICELAKE)
-# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Intel Cooper Lake (MCOOPERLAKE)
-# 31. Intel Tiger Lake (MTIGERLAKE)
-# 32. Generic-x86-64 (GENERIC_CPU)
-# 33. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
-# 34. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
-_subarch=32
+# 16. Intel Atom (MATOM)
+# 17. Intel Nehalem (MNEHALEM)
+# 18. Intel Westmere (MWESTMERE)
+# 19. Intel Silvermont (MSILVERMONT)
+# 20. Intel Goldmont (MGOLDMONT)
+# 21. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 22. Intel Sandy Bridge (MSANDYBRIDGE)
+# 23. Intel Ivy Bridge (MIVYBRIDGE)
+# 24. Intel Haswell (MHASWELL)
+# 25. Intel Broadwell (MBROADWELL)
+# 26. Intel Skylake (MSKYLAKE)
+# 27. Intel Skylake X (MSKYLAKEX)
+# 28. Intel Cannon Lake (MCANNONLAKE)
+# 29. Intel Ice Lake (MICELAKE)
+# 30. Intel Cascade Lake (MCASCADELAKE)
+# 31. Intel Cooper Lake (MCOOPERLAKE)
+# 32. Intel Tiger Lake (MTIGERLAKE)
+# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS)
+# 34. Intel Rocket Lake (MROCKETLAKE)
+# 35. Intel Alder Lake (MALDERLAKE)
+# 36. Generic-x86-64 (GENERIC_CPU)
+# 37. Generic-x86-64-v2 (GENERIC_CPU2)
+# 38. Generic-x86-64-v3 (GENERIC_CPU3)
+# 39. Generic-x86-64-v4 (GENERIC_CPU4)
+# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
+# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
+_subarch=36
# Only compile active modules to VASTLY reduce the number of modules built and
# the build time.