summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-04-24 01:02:55 +0300
committerIgor Dyatlov2021-04-24 01:02:55 +0300
commit666457dd8b66866da7315e2d178c4a4bb033662e (patch)
treeb4b1c8789a7c76eb1cf72e3df0293a9508a02729
parente0563caafb2c9af741e3870f7e4d2906516cf3ed (diff)
downloadaur-666457dd8b66866da7315e2d178c4a4bb033662e.tar.gz
Build fix
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD37
2 files changed, 10 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e8ea33f6556..5bb34498c04b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-mini
pkgdesc = Linux kernel and modules with minimal configuration
pkgver = 5.11.16
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -51,6 +51,3 @@ pkgname = linux-mini-headers
pkgdesc = Headers and scripts for building modules for the Linux kernel and modules with minimal configuration kernel
depends = pahole
-pkgname = linux-mini-docs
- pkgdesc = Documentation for the Linux kernel and modules with minimal configuration kernel
-
diff --git a/PKGBUILD b/PKGBUILD
index aac612211f3f..57191219c243 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,7 +73,7 @@ _srcname=linux-${_major}
pkgbase=linux-mini
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
pkgdesc='Linux kernel and modules with minimal configuration'
url="https://www.kernel.org/"
@@ -190,14 +190,14 @@ prepare() {
make olddefconfig
- ### Patch source to unlock additional gcc CPU optimizations
+ ### Patch source to unlock additional gcc CPU optimizations
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
echo "Patching to enable GCC optimization for other uarchs..."
patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
fi
- ### Get kernel version
+ ### Get kernel version
if [ "${_enable_gcc_more_v}" = "y" ] || [ -n "${_subarch}" ]; then
yes "$_subarch" | make oldconfig
else
@@ -205,9 +205,9 @@ prepare() {
fi
-
- make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ ### Prepared version
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
### Optionally use running kernel's config
@@ -253,7 +253,7 @@ prepare() {
build() {
cd $_srcname
- make all
+ make -j$(nproc) all
make htmldocs
}
@@ -287,7 +287,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
- depends=(pahole)
+ depends=('pahole')
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -364,26 +364,7 @@ _package-headers() {
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
-_package-docs() {
- pkgdesc="Documentation for the $pkgdesc kernel"
-
- cd $_srcname
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- echo "Installing documentation..."
- local src dst
- while read -rd '' src; do
- dst="${src#Documentation/}"
- dst="$builddir/Documentation/${dst#output/}"
- install -Dm644 "$src" "$dst"
- done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
-
- echo "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-}
-
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")