summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-01-19 22:00:17 +0100
committerPiotr Gorski2023-01-19 22:00:17 +0100
commit4a97b6b43f6597775980e135f873348b52ea8045 (patch)
treed114d9f0e28d954eb601f7cd981691976ea7053b
parentbc26134eb3a32813c1b74fb3da2172b07fe25449 (diff)
downloadaur-4a97b6b43f6597775980e135f873348b52ea8045.tar.gz
Simplifying config: change --enable to -e and --disable to -d
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dccfb4a09c9..801720527dea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-next-git
pkgdesc = Linux NEXT
- pkgver = 20230113.r0.g6b31ffe9c8b9
+ pkgver = 20230119.r0.gaa5c49149a82
pkgrel = 1
url = http://www.kernel.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 69dcafb35489..659c13343c31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20230113.r0.g6b31ffe9c8b9
+pkgver=20230119.r0.gaa5c49149a82
_srcname=linux-next
pkgrel=1
pkgdesc='Linux NEXT'
@@ -121,8 +121,8 @@ prepare() {
### Optionally set tickrate to 1000
if [ -n "$_1k_HZ_ticks" ]; then
echo "Setting tick rate to 1k..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_1000
+ scripts/config -d CONFIG_HZ_300
+ scripts/config -e CONFIG_HZ_1000
scripts/config --set-val CONFIG_HZ 1000
fi
@@ -130,7 +130,7 @@ prepare() {
# (x86 kernels do not support NUMA)
if [ -n "$_NUMAdisable" ]; then
echo "Disabling NUMA from kernel config..."
- scripts/config --disable CONFIG_NUMA
+ scripts/config -d CONFIG_NUMA
fi
### Optionally load needed modules for the make localmodconfig