summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2024-02-21 00:27:25 +0100
committerSimão Gomes Viana2024-03-13 17:56:19 +0100
commit08bca9dad7e60793b89d1ca95becd04b73dd480e (patch)
tree44f4147133ed9f8b80565d50d95fc66ee1c854a5
parent8134b178a1ed313cc22f9dbf5d41a6685a1d3df9 (diff)
downloadaur-08bca9dad7e60793b89d1ca95becd04b73dd480e.tar.gz
Install vmlinux.h
As requested by Christian, to build downstream BPF programs for the kernel. See: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/2050083 Signed-off-by: Simão Gomes Viana <devel@superboring.dev>
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2147f11a85f0..62f393993a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -93,6 +93,7 @@ build() {
makeflags="$makeflags -j$(grep -E '^processor\W' < /proc/cpuinfo | wc -l)"
fi
make LLVM=1 ${makeflags} all
+ make LLVM=1 -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
@@ -185,7 +186,7 @@ _package-headers() {
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- version vmlinux
+ version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts