summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimao Gomes Viana2019-11-05 17:41:47 +0100
committerSimao Gomes Viana2019-11-05 17:41:47 +0100
commit6fdc81947402a9114f003fda74f594207fa98e99 (patch)
treea7dc170edb17069752c5ce944204e96e455c3d19
downloadaur-6fdc81947402a9114f003fda74f594207fa98e99.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..109f51f5d392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = linux-nitrous
+ pkgdesc = Modified Linux kernel optimized for Haswell (and newer) compiled using clang
+ pkgver = 5.3.8
+ pkgrel = 10
+ url = https://gitlab.com/xdevs23/linux-nitrous
+ arch = x86_64
+ license = GPL2
+ makedepends = tar
+ provides = linux
+ conflicts = linux-nitrous-git
+ source = https://github.com/xdevs23/linux-nitrous/releases/download/v5.3.8-10/linux-nitrous-git-5.3.8-10-x86_64.pkg.tar.xz
+ sha256sums = 208ba5dbe832ed23de76c8934ed94ea87a5863ff6f69a154a91715f140b7628c
+
+pkgname = linux-nitrous
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df26e8dda705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Simao Gomes Viana <xdevs23@outlook.com>
+
+pkgname=linux-nitrous
+pkgver=5.3.8
+pkgrel=10
+pkgdesc="Modified Linux kernel optimized for Haswell (and newer) compiled using clang"
+arch=('x86_64')
+url="https://gitlab.com/xdevs23/linux-nitrous"
+license=('GPL2')
+groups=()
+depends=()
+provides=('linux')
+conflicts=('linux-nitrous-git')
+makedepends=('tar')
+source=("https://github.com/xdevs23/linux-nitrous/releases/download/v$pkgver-$pkgrel/linux-nitrous-git-$pkgver-$pkgrel-x86_64.pkg.tar.xz")
+sha256sums=('208ba5dbe832ed23de76c8934ed94ea87a5863ff6f69a154a91715f140b7628c')
+
+build() {
+ echo "No need to build anything"
+}
+
+package() {
+ cd "$srcdir"
+ make DESTDIR="$pkgdir/" install
+}