summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimao Gomes Viana2020-03-21 13:13:19 +0100
committerSimao Gomes Viana2020-03-21 13:13:19 +0100
commit3d384f74bb28d1b8ada9df7f12edb522c79f96bc (patch)
tree551d3a216a81ffdf69fe8b8ee970b118158f3344
parent7a1ae4d3df9fad39f690f956896b421eae76bd3a (diff)
downloadaur-3d384f74bb28d1b8ada9df7f12edb522c79f96bc.tar.gz
Update kernel to 5.5.11-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--linux-nitrous.install37
3 files changed, 39 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e09f9ab37338..985c9aa7e429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-nitrous-git
pkgver = 5.5.11
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/xdevs23/linux-nitrous
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 686ef5890843..f1c44e08f55a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=linux-nitrous-git
_srcname=linux-nitrous
pkgver=5.5.11
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://gitlab.com/xdevs23/linux-nitrous"
license=('GPL2')
diff --git a/linux-nitrous.install b/linux-nitrous.install
new file mode 100644
index 000000000000..6d43bb26375f
--- /dev/null
+++ b/linux-nitrous.install
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=
+KERNEL_VERSION=
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p ${KERNEL_NAME}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p ${KERNEL_NAME}
+
+ if [ $(vercmp $2 3.13) -lt 0 ]; then
+ echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
+ echo ">>> In order to use your keyboard during early init, you MUST"
+ echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
+ fi
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+}